GL-AR300M16 v3.215 VPN policy by domain does not resolve


I’m trying to set a VPN policy in my router, but looks like that only works using the IP and not the domain name.

The iplocation website can be used to demonstrate this.

With the following config:

The iplocation website shows me my VPN IP. Meaning that the policy is not applying the config “do not use VPN with the following”.

But, if I set the IP’s for the iplocation website service as:

The iplocation website gives me my IP (not the VPN IP), so it’s working.

Can you please take a look?

Thanks, André

The domain policy depends on DNS resolution, whether you have any DNS encryption on your device or something like that.

Hi @luochongjun

At the moment, I do not have any custom DNS settings, only the DNS configured with the VPN.

If this is the problem, how can I bypass this?


Have you ever tried to clear your PC’s DNS cache.
ipconfig /flushdns

The DNS in my computer is working as expected.

This looks like that the VPN policy is not resolving the domain names.

I’m coming back to this issue.

As soon I turn any specific VPN policy, I loose DNS on my computer (can’t access or dig anything).

I flush all the caches in my computer.