GL-AR750 and Sprint USB730L

I’ve just received a new AR750 with firmware version and new Sprint USB730L with the intent of using them together. They both work fine individually, the USB730L plugged into my Fedora 28 laptop is fine and the AR750 can connect as a repeater to the existing wireless but is not recognized by the basic UI. From the OS it is recognized and it looks like the appropriate modules are loaded:

root@GL-AR750:/dev# lsmod |grep usb
mii 3640 1 usbnet
nls_base 4992 8 vfat,fat,ntfs,nls_utf8,nls_iso8859_1,nls_cp437,exfat,usbcore
scsi_mod 91760 2 usb_storage,sd_mod
usb_common 2221 1 usbcore
usb_storage 38507 0
usb_wwan 4807 1 option
usbcore 122144 21 option,usb_wwan,sierra_net,sierra,rndis_host,qmi_wwan,huawei_cdc_ncm,cp210x,cdc_ncm,cdc_ether,usbserial,usbnet,ipheth,cdc_wdm,cdc_acm,usb_storage,uhci_hcd,ohci_platform,ohci_hcd,ehci_platform,ehci_hcd
usbnet 17931 6 sierra_net,rndis_host,qmi_wwan,huawei_cdc_ncm,cdc_ncm,cdc_ether
usbserial 18427 4 option,usb_wwan,sierra,cp210x

FWIW I see the AR750 periodically retrying the modem, or at least that’s my take on this:

[ 1797.361905] usb 1-1.2: new high-speed USB device number 35 using ehci-platform
[ 1797.521311] cdc_ether 1-1.2:1.0 eth2: register ‘cdc_ether’ at usb-ehci-platform-1.2, CDC Ethernet Device, 00:15:ff:82:25:70
[ 1807.452462] usb 1-1.2: USB disconnect, device number 35
[ 1807.458012] cdc_ether 1-1.2:1.0 eth2: unregister ‘cdc_ether’ usb-ehci-platform-1.2, CDC Ethernet Device
[ 1808.201872] usb 1-1.2: new high-speed USB device number 36 using ehci-platform
[12691.291815] usb 1-1.2: USB disconnect, device number 36
[12692.035017] usb 1-1.2: new high-speed USB device number 37 using ehci-platform

These are not plug/unplug events they occur while the modem is plugged in.

Based on articles I’ve seen I’m suspecting that this is an End User Mode vs. Enterprise Mode thing but all of those articles are a tad old and I figured this would have been addressed by now. Any advise out there that would not undermine official support?


USB730L perhaps support hostless mode, you should be able to set up as tethering not 4G modem.

It was a good idea but unfortunately the 3G/4G USB Modem dialog shows:

Please plug in your modem

and the Tethering dialog shows:

No phone device connected

Seems the modem is recognized then disconnected again.

If this happens, sometimes it means the power is not enough. Are you using the power adapter comes with the router? Do you have another one to try?

Figured it out. On the modem itself there are three connect mode options

  • Manual
  • Automatic if not roaming
  • Automatic

Only setting the modem to Automatic (which could cause some billing issues if travelling) will get it working for me. Not sure if there is something that can be done to address this in the firmware on the AR750 (closest thing to a console I have when operating this way) or even how to tell if the Modem is roaming from the perspective of the router but it would be cool, Don’t know how to code this, happy to be a crash test dummy…

Bottom line: problem solved but not fully optimal.

Good to hear that you solved this issue.

so you plug the modem to your pc, set up to Automatic, then plug to the router and it worked, right?

Apologies for the slow response. In addition to setting the modem to automatic I needed to install usb-modeswitch, but after that it seems to function correctly in an on demand capacity, if there is no traffic the link shuts down but reconnects automatically if there is traffic.

@camattern Does that mean you have to ssh into the GL-AR750 and reinstall usb-modeswitch every time it’s been power-cycled?