GL-AR750 / Creta: No login possible after firmware update


I have 2 GL-AR750 / Creta, using them as a Wireguard Client resp. Server.

I updated both with the latest firmware available on the GLi Page and made a local firmware update.

Both got stuck.

I was able to login in after the firmware update, checked some thing in the web interface. Then I disconnected the power, placed the server at its place and repowered it.
I can access the webgui on but the password isn`t accepted anymore (it is the correct one, copied from passwort manager). Asap I enter the passwortd, the Login-in button is greyed out and no login possible.

Happened on both devices…

Has anyone any ideas?



This seems strange. If password is wrong the UI will tell you it is wrong and you can input again.

Except for the UI, do you see that your pc get correct IP from the router?

Do you have some antivirus software preventing you input password on the UI? I have some report that bitdefender prevent you to input password on http (not https) website.

I use Firefox and Chrome, both the same.
Antivirus is Kaspersky.
And yes, I can login with all clients and using the wireguard server, which is behin my router
But no login possible to the gui.
Perhaps I have to try another laptop.

Can you try on your smartphone?

BTW, are you using a very long password, e.g. more than 32 characters?

Yes passwort is longer than 32 characters, but was working all the time. Both devices have 55 characters, with special characters for sure:) But as mentioned. Was working for 2 years

The question is… How can I change it without ressting it to scratch. First of all I will trxy another laptop. Smartphone is also not working. Same issue

I found in the Firmware Changelog:
7. Administrator password containing more than 32 characters cannot be submitted.
It`s not a good idea to allow longer passwords first and then block them…

Let me give you a workaround via private message.

I have the same problem, my password is 64 characters, 375 bits generated in keepass. Never thought that this could happen and I have not see a warning: “Updating may void your Admin password and you have to reset the complet router”.
Can someone please help me?

Can you still ssh to the router?

After you ssh to the router, edit /etc/config/glconfig and remove the password hash.

Then the UI will ask you to set up a password again.

With admin user and the password that is much too long? Does not work.

At least I found here SSH to the Router - GL.iNet Docs that I need to use root as the username, but with my set admin password. I tried different methods to verify that there is no cut & paste error of the password, I even used “putty.exe -ssh root@ -pw [here is my too long password]”. All to no avail. I get as response from the server by my root and password are not taken.

I solved the problem myself.
Perhaps you will be able to provide this information to other users as well.
Download the mobile app for glinet.
Connect to your WiFi
Start the glinet app → Control a local device
Login with the too_long_admin_password
It seems that the mobile app does not care it the password is too long (which hints that it is only checked with the browser interface, which sounds wrong but helped me)
Goto “Admin Password”, change it to a shorter password