GL-AR750 does not recognize USB iPhone (iOS 13)

I have a GL-AR750 (Creta) router and it’s working great, it runs the latest beta firmware 3.105 and when I activate my iPhone USB tethering it does not recognize anything, it says that there is no USB device connected and in my iPhone it’s not asking for any authorization. I want to clarify that I’m aware of iOS 14 tethering issues but I’m using iOS 13.5 and it’s working fine with the AR-300M. Could you please help me?

Please re-update the V3.105 test firmware, we fixed this problem.

Thank you but unfortunately it is still not working. No changes in behaviour neither on the router nor on the iPhone.

Please log in to the device via ssh and execute the following command cat /etc/version.date
Test firmware:http://download.gl-inet.com/firmware/ar750/testing/openwrt-ar750-3.105-1014.bin

I’ve tried to update with the firmware provided in your link and it happened something weird. All the LEDs on the router turn off except for the 5G one - which stays on. The settings webpage becomes unavailable and I need to power cycle it. The same happened before I told you that the problem was not fixed. After power cycling it reports:

2020-10-10 18:15:43

So I think that the update fails.

Yes, from the version information you provided, it has not been upgraded to the latest test firmware.
How did you upgrade?
Please try the following methods, I just verified that the upgrade is normal.
https://docs.gl-inet.com/en/3/troubleshooting/debrick/

Thanks for your support. It is working perfectly now! I followed the instructions provided in the link and the firmware updated correctly. Somehow the firmware failed to upgrade if uploaded through the normal upgrade procedure from the web interface. Thanks again!

1 Like