GL-AR750 doesn’t connect to hospital wifi

Hi guys,

As the title suggests, I have issues with connecting my GL-AR750 to the WiFi of a hospital.

On a mobile device, the login procedure looks like that:

  1. connect to the OPEN wifi of the hospital
  2. a page shows up, where I can enter my credentials I got from the hospital
  3. that’s it

When I connect the router to that open WiFi, the login page does of course not show up, so I can’t enter my credentials and I have no internet connection.

If the login page on the mobile device doesn’t show up, it is possible to go to and I get redirected to the correct login page. Unfortunately, this doesn’t work for the router.

Has anyone an idea, what I can try?

Thank you very much for your help!


1 Like

Oh no. Here we go again with a captive portal dilemma. I was just going through one of these episodes myself:

See if this helps you get anywhere.

Thank you for your answer.
If I understand your solution right, you connect to the GL.inet router via the 2.4 GHz band, connect to the WiFi on the router and then you were redirected to the captive portal.
I tried that, but unfortunately, the redirect didn’t work. How did this redirect look like for you? And on which mobile device did you do this?

Thank you @Almahadeus for the key word captive portal. On the Internet I found this solution.
I only had to do step 2 and 5 from solution 1 and it works now.

Thank you once again for your help! :clap:


1 Like

Many thanks @RexBalgor . I had tried all the other potential solutions and many more (I had saved about 20 different articles from these fora dealing with the dreaded captive portal problems over the years). Changing the SSID bandwidth that my terminal was connected to was the only thing that worked during my latest battle. DNS Rebinding Attack Protection option should have been disabled by default on the newer firmware versions anyway.

Luckily the solution for me was a bit easier. :smile:

I have the latest firmware for my router installed and the DNS rebinding protection was enabled. :man_shrugging:

1 Like