GL-AR750S-EXT and OpenVPN on 3.212 version

I’ve a GL-AR750S-EX with 3.025 version and OpenVPN activated.
I’ve patched it to avoid the “default redirection all through the vpn” … and all worked fine.
I also have a direct visibility between single OpenVPN client node.
Now, after upgrade to 3.212 version:

  1. Patch don’t works (but… I’m trying to use “VPN policies” …)
  2. Ping between client nodes don’t works
  3. Ping from server to clients works but I can’t access (e.g.) to client http, ssh services …
    Any suggestion ?

In the vpn connection page, there is an option “allow local access” you need to tick it.

Hi, and thank you for replay
I’ve already tried it … but seems don’t works
I will repeat the test now with a clean conf

Pls test. If does not work, I can test more. But just better to have a more detailed setup so that I can exactly like you.

I’ve done a total conf reset e firmware upgrade.

  1. I’ve about 20 GL-AR750S-EXT in production with 3.025 firmware. The only (initial) problem I have is that, for exclude “normal” traffic from VPN, a patch is required. But all works FINE: I regularly access to all client node and to SSH server services (VPN routed subnets).
    (scenario “1” of attached file)
  2. On one of this router I’ve updated firmware to 3.212 and OpenVPN don’t works for version incompatibiliry with server
    (scenario “2” of attached file)
  3. Adding “data-ciphers BF-CBC” parameter to ovpn conf, OpenVPN connects to server … but (by default) all traffic is through VPN
    (scenario “3” of attached file)
  4. Initially all works fine … but after some seconds I cannot access to nodes and to server services.
  5. Only restarting router or restarting firewall (from OpenWrt Luci interface) all come to work for some time …
  6. Use of patch is another topic … I hope to avoid it using VPN Policies …

In summary:
On this firmware version it seems OpenVPN is unstable …

Detailed Server and client conf: GL.inet (1.6 KB)


Hi, can you remove the “comp-lzo” config. server and client remove this config. test it can work fine?

the ovpn version more then 2.4, the comp-lzo config is remove. the 3.212 version, ovpn version is 2.5.2, the LZO config update to: compress lz4-v2.

this is the ovpn version diff problem.

I’ve tried to remove either on server and client “comp-lzo” option and VPN works fine.
The need to use the default redirection all through the vpn … patch remains … because, using VPN policy, input from other VPN nodes is inhibited

Thank you.

@hilll will help to investigate the routing problem.

ovpn routing set lan to lan, have to config as follow:

  1. ovpn server config set the client conf, as:
    client-config-dir /etc/openvpn/ccd

int the /etc/openvpn/ccd directory, create each client conf, as:



  1. int the /etc/openvpn/ccd/xxx client config, set as:


set the iroute is the client subnet; so ovpnserver can route the ovpnclient.

reference help: