GL-AR750S-EXT Crashes when Trying to Connect


My two GL-AR750S-EXT used to work. After trying to update the firmware, I cannot get either one to function.

I successfully updated both to 3.211 and then 3.212. Immediately after updating, I was able to use the web interface, connect a switch and two devices downstream of the switch, and tether my iPad. As soon as I cycled power on the router, I cannot access the web interface anymore.

With nothing plugged in, the router appears to boot and both the 2G and 5G lights eventually turn on.

As soon as an ethernet cable is plugged into the router, the 2G and 5G lights immediately shut off and it appears to reboot. Leaving the cable in, it reboots every 84 seconds (presumably it gets to whatever stage in the boot process and just hangs there). I can’t ping it, because it fails to assign an IP address to anything that gets plugged in (or it’s rebooting as soon as it tries for some ungodly reason). For the same reason, I can’t ssh into it, either (no IP address assigned). Manually assigning the IP address to the 192.168.8 subnet does no good, either.

Likewise, if I try to connect to it via wi-fi, instead of ethernet, it exhibits similar behavior. Before I can enter the passkey, it reboots.

On the other router (also successfully updated to 3.212), I had the exact same issues. I tried reflashing via the de-bricking procedure to 3.104, which was successful, but then the same thing happened. After I cycled power, the same bizarre rebooting behavior was occurring. Now I’m stuck. As soon as a I plug in a cable or attempt to connect via wi-fi, it reboots. Because I can’t get into the web interface, I can’t get past 3.104.

I really need to have a working travel solution for this upcoming Saturday, but it isn’t looking good. I’ve wasted at least two days trying every permutation I can think of to get either one of these working, but it’s just looking more grim with every iteration.

I tried updating UBOOT and directly applying 3.211 and 3.212 on one of the routers, as well. No change in the behavior.

1 Like

Could you try flashing the beta software through uboot?

I don’t personally own this model, but it’s worth a shot. A clean new firmware will hopefully fix it. Make sure you select the uboot version. (The lowest download link).

There is also a snapshot, but the beta is usually more stable.

Possible power issue?

What AC adapter and power cable are you using?

IIRC - the one supplied is 5.0vDC 2.0A - I’ve seen first hand on AR750 if one is using lower current rated adapters that it will brown out and reboot.

Oddly enough, this DID work for both routers. I’m still not quite understanding why I had to install beta firmware when previous versions had worked flawlessly in the past. I’m not feeling too goo good about relying on these Slates for anything important at the moment, and hopefully the issue doesn’t return (fingers crossed).

Either way, though, it saved my weekend plans this time around, so thank you!


Good thought on the power supply, but I did already try a few different phone charging adapters and surge strip integrated supplies (some rated up to 5V@3A) with the same idea.

Ultimately, the suggestion to install beta firmware worked when using at least a couple of the supplies I had used while experiencing the reboot issues. As such, I’m leaning toward discarding inadequate power supply as the root cause for now.

Thanks for the input, though!