GL-AR750S Slate seriously

Very confused…How do I get my Slate back to the factory firmware and web interface?

The only success I’ve had using the Uboot method is to install the clean 3.0 firmware, but it brings up Luci and it is buggy/unforgiving. None of the other firmware versions seem to work…they are all OpenWRT and I can’t get to any web UI other than Luci…

Very perplexed as to how I painted myself in this corner… /grumble :angry:

1 Like

Hey :wave:

Try flashing the oldest image through uboot:

After that, flash the latest:

Let me know how it goes :slight_smile:

Tried that earlier. The latest firmware always fails with an error indicating its size is an issue. Get the same result for most of the firmware versions after 3.104.

Is booting into Luci vs Admin Panel configurable somewhere?

Should happen automatically.

But since you can access Luci, we’ll use that😄

Go to System/Backup / Flash Firmware & select Flash Firmware.

Select the latest V3 image. If it says that verification check fails, select the force option. Don’t keep settings.

After this is done, you’ll boot into uboot, but Luci etc is completely removed. Now you should be able to flash the latest V3 image again in Uboot.

Thank you for your help…I’m getting an error “The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.”

I picked the “openwrt-ar750s-3.212-0407.img” file I downloaded earlier.


Is this for flashing in Luci or Uboot?

Either way, I believe for Luci you need to use the system upgrade image (the .tar file)

For uboot you need the uboot image (the .img), pretty obvious😄

Same error for both… :upside_down_face:

Hmm that is odd😄

Is there no option to force upgrade?

Nope. Just that one checkbox for saving settings or not.

There is a “perform reset” button under the Restore heading (reset to defaults). Do you think that would do anything productive?

Worth a shot I think👍

Well… here goes nuttin :crossed_fingers:

1 Like

“The system is erasing the configuration partition…”


If it doesn’t work, you could try flashing the snapshot through uboot:

Yeah, I’ve been trying the uboot options…if it doesn’t fail outright, then I get put on the Luci UI on the gateway, not the GL iNet UI via the gateway.

Well…after the reset it lost its config for my network, so I need to get under the desk to wire the router into the back of my pc again…


So how exactly did this happen anyway? Did you try to downgrade, or were u using an OpenWRT image, or just a reset that got stuck somehow?

I’m back! And so is the router!

The “reset to defaults” option must have cleared out the junk because I was able to flash a recent firmware via uboot and then regained the GL Admin Portal and gateway IP.

I honestly don’t know when I last used this thing. I must have mucked it up over two years ago and it’s been sitting in my closet ever since. Thanks again for the ideas Bobbie01! :star2:

1 Like

I think I remember something about needing to upgrade to 3.105 and then being able to upgrade to the newest firmware on this device


Awesome, have fun with the device :smile: :clap:

1 Like

I am trying one of those paths now, just to see if I can get to a more current version…

1 Like

I have just gone through the whole U-boot flashing fail error procedure, I am now back to the latest beta firmware.

My best smoothly flashing “guide” is as the following :laughing:

After try&error for couple times, the “best” flashing “path” is as the following:
v3.001(Uboot img) OR v3.104(Uboot img) → v.3.105 (sysupgrade tar through web gui local upgrade) -->v.3.212 (web gui system auto check upgrade) → latest 3.215 beta 2 (local upgrade)

What an exciting flashing journey :upside_down_face: