Gl-ar750s

Hello guys,

my router keeps disconnecting in repeater mode with master network:

Sun May 10 03:44:52 2020 daemon.notice netifd: Network device ‘wlan-sta’ link is down
Sun May 10 03:44:52 2020 daemon.notice netifd: Interface ‘wwan’ has link connectivity loss
Sun May 10 03:44:52 2020 kern.info kernel: [44334.247100] wlan-sta: deauthenticating from 88:f8:72:0c:ae:2a by local choice (Reason: 3=DEAUTH_LEAVING)
Sun May 10 03:44:53 2020 daemon.notice netifd: wwan (32347): udhcpc: received SIGTERM
Sun May 10 03:45:40 2020 daemon.warn dnsmasq[3092]: no servers found in /tmp/resolv.conf.auto, will retry
Sun May 10 03:45:40 2020 daemon.notice netifd: Interface ‘wwan’ is disabled
Sun May 10 03:45:57 2020 user.info : [ 1470] gl-wifi-core>> wifi(radio) scan failed. Use phy to scan…
Sun May 10 03:45:57 2020 kern.info kernel: [44398.551007] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Sun May 10 03:45:57 2020 kern.info kernel: [44398.565725] IPv6: ADDRCONF(NETDEV_UP): tmp.phy0: link is not ready
Sun May 10 03:46:03 2020 user.info : [ 1476] gl-wifi-core>> wifi(phy) scan failed. Use wlan to scan
Sun May 10 03:46:09 2020 kern.info kernel: [44411.338497] IPv6: ADDRCONF(NETDEV_UP): tmp.radio1: link is not ready
Sun May 10 03:46:09 2020 kern.info kernel: [44411.371099] IPv6: ADDRCONF(NETDEV_UP): tmp.radio1: link is not ready
Sun May 10 03:46:11 2020 user.info : [ 2607] gl-wifi-core>> bIsStaEnabled=1
Sun May 10 03:46:12 2020 daemon.notice netifd: radio1 (23094): Successfully initialized wpa_supplicant
Sun May 10 03:46:13 2020 daemon.notice netifd: Interface ‘wwan’ is enabled
Sun May 10 03:46:13 2020 kern.info kernel: [44415.296346] wlan-sta: authenticate with 88:f8:72:0c:ae:2a
Sun May 10 03:46:13 2020 kern.info kernel: [44415.314760] wlan-sta: send auth to 88:f8:72:0c:ae:2a (try 1/3)
Sun May 10 03:46:14 2020 kern.info kernel: [44415.423527] wlan-sta: send auth to 88:f8:72:0c:ae:2a (try 2/3)
Sun May 10 03:46:14 2020 kern.info kernel: [44415.533498] wlan-sta: send auth to 88:f8:72:0c:ae:2a (try 3/3)
Sun May 10 03:46:14 2020 kern.info kernel: [44415.541150] wlan-sta: authenticated
Sun May 10 03:46:14 2020 kern.info kernel: [44415.553564] wlan-sta: associate with 88:f8:72:0c:ae:2a (try 1/3)
Sun May 10 03:46:14 2020 kern.info kernel: [44415.663493] wlan-sta: associate with 88:f8:72:0c:ae:2a (try 2/3)
Sun May 10 03:46:14 2020 kern.info kernel: [44415.673813] wlan-sta: RX AssocResp from 88:f8:72:0c:ae:2a (capab=0x431 status=0 aid=58)
Sun May 10 03:46:14 2020 kern.info kernel: [44415.682371] wlan-sta: associated

I tried all firmware versions available. Right now I’m on 3.104.

I’m struggling with it for 2 weeks now… keeps driving me crazy.

On 3.104 ipv6 is disabled. Why you still have ipv6 message?

The log is not complete. Can you post your complete log? Can you also make sure you didn’t clone mac address etc.?