GL-ARM300M16-EXT extender problems

Hello Everyone,

I have a MUDI Router. Since its range is not very impressive, I purchased the GL-AR300M16-EXT to extend it.

I have done over 10 factory resets and still don't understand how to get this device to work correctly.

Here's what I do:

  1. I go to the router settings, then to Network Mode, and select "Extender".
  2. I search for the Wi-Fi network I want to extend, which is from the MUDI, and press Save.

The router connects to the Wi-Fi network according to the MUDI and gets an IP address assigned via DHCP. However, I can no longer access the AR300M under that IP address.

When I check (in the UNIFI environment), I find several Wi-Fi networks:

  • My Wi-Fi from the MUDI (with matching channels under Advanced settings)
    • 2.4 GHz Channel 3
    • 5 GHz Channel 36
  • Additionally, there is another 2.4 GHz network on Channel 6.

I assume Channel 6 is the extended channel from the AR300M, but it seems to ignore the 5 GHz channel.

The worst part is:

The Wi-Fi network "GL-300M-xxx" still exists. When I connect to it, I get an IP address from the MUDI Router's range and have FULL access with the password "goodlife". However, I can't access the AR300 anymore; it just disappears.

The most important question is:
How can I regain access to the AR300?

Although there is info under "Network":
"When you use Access Point / Extender / WDS mode, you may not connect to this UI again. You can press and hold the reset button for 4 seconds to revert to router mode. Learn More >"

But under "Learn More," there is no further information on this topic!

I can reset the router (4 seconds), and my password even remains the same. However, as soon as I set it to extender mode again, I am back to square one.

What should I do next? Does anyone have a solution?

Thank you!


Moin :wave:t2:

please refer to this thread to see how you can enable the GUI even in repeater / extender mode: GL-B1300 v4.3.17 has odd network settings

1 Like

Hello Everyone,

I've temporarily set the firewall rule on the AR300M to any-any-any, which allowed me to access the IP address after the configuration change.

However, my enthusiasm is limited.

Currently, I'm testing the setup at home:

  1. 250MBIT VDSL ->
  2. MIKROTIK Router ->
  3. UNFI WLAN (still fast) ->
  4. MUDI as a Client in the WLAN -> 20 Mbps ->
  5. AR300M -> 3 Mbps.

But it only works briefly; then the AR300M crashes and becomes unreachable until I power cycle it.

Does anyone have a solution for these issues?

Thank you!


Tue Jul 9 17:16:24 2024 daemon.info lua: (...07/ipkg-mips_24kc/gl-sdk4-repeater/usr/sbin/repeater:548) <3>Associated with 96:83:c4:37:83:95
Tue Jul 9 17:16:24 2024 daemon.notice wpa_supplicant[2025]: wlan-sta0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Tue Jul 9 17:16:24 2024 daemon.info lua: (...07/ipkg-mips_24kc/gl-sdk4-repeater/usr/sbin/repeater:548) <3>CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Tue Jul 9 17:16:24 2024 daemon.notice wpa_supplicant[2025]: wlan-sta0: WPA: Key negotiation completed with 96:83:c4:37:83:95 [PTK=CCMP GTK=CCMP]
Tue Jul 9 17:16:24 2024 daemon.info lua: (...07/ipkg-mips_24kc/gl-sdk4-repeater/usr/sbin/repeater:548) <3>WPA: Key negotiation completed with 96:83:c4:37:83:95 [PTK=CCMP GTK=CCMP]
Tue Jul 9 17:16:24 2024 daemon.notice wpa_supplicant[2025]: wlan-sta0: CTRL-EVENT-CONNECTED - Connection to 96:83:c4:37:83:95 completed [id=0 id_str=]
Tue Jul 9 17:16:24 2024 daemon.info lua: (...07/ipkg-mips_24kc/gl-sdk4-repeater/usr/sbin/repeater:548) <3>CTRL-EVENT-CONNECTED - Connection to 96:83:c4:37:83:95 completed [id=0 id_str=]
Tue Jul 9 17:16:24 2024 kern.info kernel: [ 105.598997] br-lan: port 2(wlan0) entered blocking state
Tue Jul 9 17:16:24 2024 kern.info kernel: [ 105.604504] br-lan: port 2(wlan0) entered forwarding state
Tue Jul 9 17:16:24 2024 daemon.notice netifd: Network device 'wlan0' link is up
Tue Jul 9 17:16:25 2024 daemon.notice netifd: wwan (5122): udhcpc: started, v1.35.0
Tue Jul 9 17:16:25 2024 daemon.info lua: (...07/ipkg-mips_24kc/gl-sdk4-repeater/usr/sbin/repeater:1239) connected to 'Schwarzbrot(96:83:c4:37:83:95)' channel: 3, spent 2s
Tue Jul 9 17:16:26 2024 daemon.notice netifd: wwan (5122): udhcpc: broadcasting discover
Tue Jul 9 17:16:26 2024 daemon.notice netifd: wwan (5122): udhcpc: broadcasting select for 172.20.20.69, server 172.20.20.200
Tue Jul 9 17:16:26 2024 daemon.notice netifd: wwan (5122): udhcpc: lease of 172.20.20.69 obtained from 172.20.20.200, lease time 43200
Tue Jul 9 17:16:26 2024 user.info mwan3rtmon[4411]: Detect rtchange event.
Tue Jul 9 17:16:27 2024 daemon.notice netifd: Interface 'wwan' is now up
Tue Jul 9 17:16:27 2024 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Tue Jul 9 17:16:27 2024 daemon.info dnsmasq[1]: using nameserver 172.20.20.200#53
Tue Jul 9 17:16:27 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Tue Jul 9 17:16:27 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Tue Jul 9 17:16:27 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Tue Jul 9 17:16:27 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Tue Jul 9 17:16:27 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Tue Jul 9 17:16:27 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Tue Jul 9 17:16:27 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Tue Jul 9 17:47:35 2024 user.notice firewall: Reloading firewall due to ifup of loopback (lo)
Tue Jul 9 17:47:42 2024 user.notice mwan3[5642]: Execute ifup event on interface wwan (wlan-sta0)
Tue Jul 9 17:47:44 2024 user.notice mwan3[5642]: Starting tracker on interface wwan (wlan-sta0)
Tue Jul 9 17:47:48 2024 user.info mwan3rtmon[4411]: Detect rtchange event.
Tue Jul 9 17:47:50 2024 user.notice firewall: Reloading firewall due to ifup of wwan (wlan-sta0)

In extender mode, to access the web panel, change your pc's IP manually to 192.168.8.x

Here's the translation into English:

Hello,
the problem has already been solved, see above.

However, the AR300M is extremely slow. Out of my 250 Mbps, only 3-6 Mbps are coming through. The MUDI is also very slow, but behind the AR300M, it's extreme.

Additionally, the AR300M often loses the WLAN connection to the MUDI, usually during the speed test. If you wait a few minutes, it reconnects again. If you restart the AR300M, it connects immediately again.

You are using 2.4G for repeater and wifi, it will be slow.
Should not be that slow. Maybe somewhere can be optimized.

Hello,
thank you for the detailed and helpful response. I was expecting to get some information on what I can optimize?

How can I eliminate the connection drops?

I think one should understand the devices and be able to support them if one is selling them to customers. That's why I'm doing all this.
However, I am close to giving up and not selling a mobile solution to my customers. They will just have to plug a Mikrotik into the socket, that works. Unfortunately, they are always so big when they have LTE and WiFi.

It's difficult to help without completely understanding the whole setup.

In general, the AR300M isn't powerful and therefor a bottleneck just by its existence. Same for Mudi since it's not built to be used with repeating mode. It might work, but it's not intended to be used like this.

My first advice would be to lock the Mudi to 5 GHz while repeating.

(It is somewhere in the repeater settings)

Hello, the setup is described above.

So, should I not use the MUDI as a client in the WLAN for better performance? Is it not built for that? I understood that this is exactly what it's intended for. To create a private LAN in hotels and use either the hotel WiFi or LTE? I would have assumed that WiFi is faster. Exactly the features that the Mudi is not designed for are described in the description as the reason why one should buy it.
I don't understand.

If I set the MUDI to 5 GHz, then the AR300M cannot repeat, because it can only do 2.4 GHz, right?


My Setup:

The MUDI receives internet via WLAN (2.4GHz) as a client (250 Mbps) or LTE about 50 Mbps via the SIM card:
configured via the GLI interface.
WLAN on the MUDI for clients:
2.4 or 5GHz, no guest WLAN.
Here, a maximum of 20 Mbps is achieved, if lucky.

The AR300M
has been reconfigured multiple times.

Firewall rules (any, any, any)
Set up as a repeater for the WLAN from the MUDI.
It only shows 2.4 GHz as options.

I can't set the WLAN for clients to 5GHz, as some devices have issues with it.