GL-AX1800 Flint snapshot 3.208

I noticed new snapshot firmware available for Flint.
Are there any release notes available?


We only have release notes for stable and beta versions. If you want to download the snapshot, you can check here: ax1800 beta firmware

The snapshot of 20211213 is for specific users to test, please don’t try it.

Strangely enough, this snapshot version has been the most stable one for me so far. The combination of running AdGuardHome, Wireguard PN Client and Portforwarding have all been working with no conflict like it used to happen with all the prior versions. Fingers crossed that this will continue to be the case.

1 Like

OK so who is supposed to install this snapshot? What issues does it resolve?
I am always keen to try the latest :slight_smile:

Major features added traffic and load balancing and upgraded AdGuardHome.

1 Like

I installed the snapshot version and yes, it’s the most stable version so far. Also the wifi coverage and performance is better than 3.207


Has this more Wi-Fi channels available, it’s very limited on both 2.5 & 5.8gHz, if you go into LuCI it can’t even be changed there.

1 Like

The snapshot version for Flint, 3.208, seems to work well and the problem with adguard seems partially solved, at least in my tests during the last 24h. Current stable version, 3.207, has problems with adguard, freezing internet connection until you disable adguard.

What I noticed, NextDNS don’t work with the 3.208 snapshot.
It just uses my regular DNS server provided by my provider.

I think ill just give it another try if it fixes so many other issues I am seeing, but a not working NextDNS is definitely a show stopper for me.

Is anyone els having issues with this snapshot and NextDNS?

1 Like

Option 1. Did you try to disable rebind protection both on the router and nextdns?

Option 2. If that didn’t work out, have you tried to verify the metrics in the lan interface in luci under advanced? Is it 0 or 10?, Try a different metric (from my experience it fixed also other issues to vlans dropping for example), make sure to restart.

Option 3.
Update busybox to 1.28.3_4 as noted here Flint dhcp issue - #2 by Vityacv this fixes chattyness and also dropping dhcp.

For me it runs stable on 3.208 with rarely a wifi disconnnect and I use only ipv4.

I cant find 3.208 on download page or in router’s update page. How can I download?

3.208 has been removed just looked, i did download it but haven’t got it now so i hope i don’t need to reinstall it but all working fine this end.

Yes, it has disappeared from the download list for some reason. May be it will be added as a stable version instead?

Hmm, it could have been removed for safeguarding reasons or maybe they generate a newer version.

I mean these snapshot builds shouldn’t be threated as production build, and I believe you should threat them as having a higher possible chance of bricking your device.

Especially with these builds you need to be alot more informed or it could cause a brick, or even some software doesn’t work.

I kinda compare it to what I always did on dd-wrt, always looking to others and checking for the exact version and only as last resort, if you can wait, then wait, better safe than not.

with version I also look to the compile time

Sorry that I deleted it yesterday, just because too much snapshot files.
@lizh will upload a latest version later.

@Almahadeus @xize11

ax1800 beta firmware


Thanks lizh. Is this version exactly the same as the snapshot one or has it been further modified?

Some modifications have been made. Such as the Busybox: Delete Delete MSG_DONTROUTE flag.


I have found out that the crash log is literally full of the following errors, happening all day and night: (the log has risend to 3.3 MB for a week…)

Thu Jan 13 08:48:45 2022 daemon.err openvpn[6418]: TLS Error: reading acknowledgement record from packet
Thu Jan 13 08:49:45 2022 daemon.err openvpn[6418]: TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Thu Jan 13 08:49:45 2022 daemon.err openvpn[6418]: TLS Error: TLS handshake failed

the IP addresses are random. Please note that the OpenVPN server is enabled and works, but it is not used at all, it is just active! So, it is very strange, or I don’t understand what these random IP adresses and TLS handshare fails are, happening 24x7 when the server is not connected to at all?!