GL-AXT1800 Update 4.5 - Wireguard VPN Bug

Hi,
I did an update from my Slate AX (GL-AXT1800) version 4.4.6 to 4.5. I have a Wireguard server configuard and in use since version 4. I have around 10 clients connected to it. Since this upgrade I can no longer Access IP Subnets outside of the local LAN. I logged some of the packets, they all have “bad IP checksums”. I did a reboot, a reset, a tunnel disconnect, a Wireguard server on/off, setting MTU low as 1300 nothing helps. After 2h of troubleshooting, I reverted back to version 4.4.6 and everything is working again.

Is this known?

cheers

1 Like

I’m having issues with 4.5 also.
Internet connection dropping on the cliente.
I use two AXT1800.
I will try to downgrade now and see if it fix.

Hi @GL, I tried 4.5.16 and still got the same result all Wireguard Clients can not connect to the Internet, as the GL-AXT1800 is sending broken pakets:


In the picture 10.0.0.2 is the Gl-AXT1800, I don`t know why it produces a bad IP checksum in the pakets after the firmwar upgrade from 4.4.X to 4.5.X.

With Version 4.4.x everything is running. Can you please have a look why this happens?

1 Like