GL-B1300 not working with Quectel EC25 LTE


#1

I use almost every version of GL-iNet router that is made. So far all of them will accept a Quectel EC25 on a USB adapter board as if they were the GL-MiFi itself. They all seem to work seamlessly with the EC25 adapter board inserted into their USB port. However, I really need the B1300 to have LTE capability and nothing is working. I’m not sure if the current software lacks the drivers (2.72), or what. I’ve tried the external USB 3 and the internal USB 2. Nothing works.

Until GL-iNet adds LTE to its B1300 base software (everybody needs LTE failover from time to time, no?), how can I add those drivers and what other software would be needed (PPPD?, QMI?, etc?)?
Thank you very much for anybody that can help me.


#2

Unfortunately, B1300 uses QSDK, whose kernel is 3.14, while EC25 driver depend on kernel version >= 4.9.

BTW, we will release v3.0 firmware soon, which has upgraded the kernel to 4.4, will check if it can work in 4.4.


#3

Wow, yeah I saw QS:cloud_with_lightning:DK when I SSH’ed into it. I guess I overlooked the fact that the linux kernel was so old. That is very disappointing. When Ver 3.X software comes out I think we can make kernel 4.4 work with the EC20/EC25 from what I recall.
Thank you.


#4

B1300 testing firmware is out with kernel 4.4 now. Pls try.


#5

I’ll try it.
Thank you.


#6

I tested the B1300 with the new firmware and it would recognize that there was a modem there, but the “Modem Name” would not display the type of modem (I tried Quectel EC20, EC25, & EP06). It would also not allow manual setup using the GUI. Is there something else this device needs to be able to run a LTE modem?


#7

Can you try Luci or set up manually using ssh?