GL-B1300 using as secondary AP

Hi, i’m struggeling to setup an GL-B1300 as an secondary AP and VLAN switch without any rounter functionality.

First i’ve switched to OpenWRT 18.06.1 to have a fresh and latest OpenWRT via TFTP.

Then I noticed that switch0 only is showing LAN1 and LAN2 within Luci no WAN can be used here. That’s pretty strange. Even within the /etc/config/network i can’t see any VLAN2 and port 5 settings within switch0.

But anyway i don’t care because i do not want to use it as an router. It should be only an AP and 3 Port VLAN switch behind the main OpenWRT router.

Therefore i changed (referring https://openwrt.org/docs/guide-user/network/wifi/dumbap)

config interface lan
option type ‘bridge’
option ifname ‘eth0 eth1’ # Bridges lan and wan
option proto ‘dhcp’ # Change as appropriate

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘0t 3 4 5’

disabled dnsmasq
disabled odhcpd
disabled firewall

restarted network

But this does not work. The router is unreachable now.

Because of the strange switch0 settings i’m unsure now if i did everything correctly.

Did i forget anything?

Regards

Do you have a try delete those lines?

Delete? Why? I need vlan1 as a native vlan on those ports right?

So no hints for me? Maybe some employee?

I have tried, it works for me on AP mode. Here is my configuration files.

/etc/config/network

root@OpenWrt:/# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd68:68a4:0024::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'dhcp'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0 eth1'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'none'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname 'none'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '3 4 0'

/etc/config/dhcp

root@OpenWrt:/# cat /etc/config/dhcp 

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

Ok thanks a lot. i will give it a try with your way.

What about the wan port. I don’t see the port in your switch0 config. I would like to use it as a trunk port with tagged vlan.

In AP mode, we just need bridge all interfaces together.

So if i want to use the WAN port as a trunk i just include:

config switch_vlan
option device ‘switch0’
option vlan ‘400’ #some VLAN
option ports ‘5t 0t’ # port 5 is wan with tagged vlan, port0 is the CPU with tagged vlan

Right?

Does it work for you? I think it doesn’t need the tag. You can change to option ports ‘5 0’

Hi, not really. The unit configuration is pretty strange and i wasted a lot of time. I managed it now with an old WDR4300 and could set it up in the usual way within 10 minutes. The switch config of the BL1300 is so weird and new interfaces bridged to software VLAN just did not work without any reason. With another units and comprehensibly switch config the configuration is no problem. Honestley i think the BL1300 has a big hardware bug and it seems the OpenWRT images for the unit, too.

Now i figured out what the problem is with this device. It is just unable to handle manually configured vlan interfaces… That’s pretty bad for a router and this means the unit is unusable for the most configurations.

As long this patch https://github.com/chunkeey/LEDE-IPQ40XX/commit/a04cf208fe317074502f7ea81dafa828c89b74bb
is not a part of the openwrt upstream the unit does not make sense.

regards
Dirk

1 Like

Does this only affect official OpenWRT firmware or also GL.iNet firmware?

It is fairly straight forward and intuitive if you are willing to use luci. I just did so for a couple of B1300’s yesterday. I will put together instructions once I get home.

1 Like

Thanks that’s great. Are you also using additional interfaces with vlan?

I am really looking forward to your instructions! Thanks in advance!

Perhaps I’m missing something, but what is the purpose of the vlan? Don’t you just want to use the B1300 as a traditional Access Point? Essentially allowing wireless clients to join the hardwire LAN coming into the B1300?

In my case, I do not need to use the device as a switch, bridging multiple ethernet connections. The standard config has two ethernet ports for LAN and one for WAN. If you need three ethernet cables coming in to the B1300 and you want them all to be treated as the same LAN, it seems that you would just bridge them together, as mentioned by kyson-lok. I can try it before sending my directions.

In my case - which may be very different from dersch’s - I “just” need the two VLANs 100 (main client LAN) and 110 (guest LAN) to be trunked to one physical interface and bridged to two different WiFi SSIDs. I try to get this working on LAN1 and want to use WAN as a rescue/fallback interface with static IP. So, in my case, I do not require all three physical interfaces.

That’s the problem. The architecture of the device does not allow to use vlan on other interfaces. The are just ignored by design. I found the patch i posted 6 days ago but it is not merged into the openWrt master until now.

OK, I wrote up this long tutorial, but I fear it will not help either @micmon or @dersch, due to your need to configure VLAN. In any case, here it is for others who want to use a B1300 as a simple AP.

Here are instructions for connecting the B1300 to your network as an Access Point, meaning:
• There is separate Main Router, which is providing all the DHCP addresses to the clients, performing firewall functions, providing DNS. For this example, I will assume that the LAN IP address of this Main Router is 192.168.25.1, and will be providing DHCP in the space of 192.168.25.X
• The AP we are setting up will eventually have the IP address of 192.168.25.2, but since it is just being set up for the first time, will have the default IP address of 192.168.8.1 (we will configure the new IP address below)
• The B1300 has two ethernet ports marked as LAN (with a <–> symbol) and a third WAN port (the one closest to the power connector). In this guide, we will only use the two LAN ports. If you wish to reconfigure the WAN port to act as a third LAN port, that it out of scope of this guide, but some instructions will be added to the end of the guide to accomplish this.
• All of the wireless clients that connect to this AP will be on the same LAN as the LAN side of the Main Router, i.e. receive an IP address from the Main Router in the range of 192.168.25.X. As such, all of the wireless clients should be able to connect to all other LAN devices, including those wireless clients connected via the Main Router.
I do not use IPv6 on my network, so I will be ignoring those configuration steps.
Step 1 (boot up B1300): Unbox the B1300, attach the power cable and let it boot up. (Let me know if I need to add more detail.)
Step 2 (connect computer to B1300): Connect a computer with a web browser to the LAN side of the B1300, either by connecting by ethernet (installed in one of the LAN ports of the B1300), or by connecting wirelessly. Since the B1300 is still in its default state, the B1300 will have the LAN IP address of 192.168.8.1, and your computer will be given an IP address 192.168.8.X. (Let me know if you need more detail.)
Step 3 (Access luci interface of B1300): Open up the computer’s web browser and go to address 192.168.8.1 (the B1300), then navigate to the luci interface. If you are using the default GL-Inet firmware, you will need to choose language, time zone and a password, then click on the Advanced settings in the upper right corner. If you get a warning pop-up. Hit OK, then log in again to the luci interface.
Step 4 (Configure IP address of B1300): From the pull-down menu at the top of the page, select Network, then Interfaces. At the top, you will see a LAN Network, as well as one or more WAN Networks. Click on the Edit button associated with the LAN. Make the following changes:
• IPv4 address: Change to 192.168.25.2 (or whatever address you will use to reconnect to this B1300).
• IPv4 gateway: Change to 192.168.25.1 (or whatever address you use for the Main Router).
• Use custom DNS servers: Change to 192.168.25.1 (or whatever address you use for the Main Router).
• Click on the Advanced Settings, and confirm that “Bring up on boot” is checked.
• Click on Physical Settings, and confirm that Bridge interfaces is checked, and that in the Interface list below, the Wireless Networks and the lan Ethernet Adapter are all checked.
• Click on Firewall Settings and confirm that lan is selected.
• Scroll down to DHCP Server, and under the General Setup tab, click the box that says “Ignore Interface” so that there is a check mark in that box. This tells the B1300 not to issue its own set of IP addresses when new devices connect, but instead allows the Main Router (as assigned as your gateway) to serve as the DHCP server.
• Leave all other entries in their default state
• Click Save & Apply
At this point, the B1300 will bring down, then bring back up, its Interfaces, but using its new LAN IP configuration. If you have not before, plug your B1300 into your wired network, i.e. take your ethernet cable from you network and plug it into one of the two LAN ports (with a <–> symbol). (Make sure not to connect it to the WAN port.) Now reboot the B1300 by unplugging the power cord for a few seconds, then re-plugging the power cord into the B1300.
Now reconnect to the B1300’s luci interface by directing your browser to 192.168.25.2. This can be a little tricky, especially if you are configuring your B1300 over wireless. Make sure your computer is connected to the B1300’s ESSID, not another available wireless network. Also, you may need to refresh your browser page if it is showing a cached version of 192.168.25.2.
Before moving to the next step, confirm that you are connected to the LAN side of your Main Router, either by pinging it, or go to 192.168.25.1 on your browser and confirming that you see the Main Router’s configuration page. Once that is done, check to see if you are connected to the internet by connecting to a few websites.
Troubleshooting:
• Confirm that, if you are configuring your B1300 over wireless, your computer is connected to the B1300’s wireless network.
• Confirm that your B1300 is connected to your wired network via a LAN port, not a WAN port.
• Reboot both the B1300 and your computer, to assure that the newly-configured correct IP addresses are used on both devices.
• Confirm that your computer now has an IP address assigned by the Main Router in the range of 192.168.25.X

Step 5 (Configure wireless): At this point, the main work is done. Your B1300 should be operating as an Access Point. But, while not necessary, you likely want to change the name and security of the wireless network provided by your new AP. From your computer, return to the luci configuration at 192.168.25.2. From the pull-down menu at the top of the page, select Network and then Wifi. You will see the two wireless configurations, one for 802.11bgn, the other for 802.11anac. Click on the Edit button for the first wireless configuration, then make the following changes:
• Scroll down to the Interface Configuration, on the General Setup tab. Change the ESSID to which ever wireless ESSID you want (what people will see when they scan for available wireless networks).
• Confirm that the Mode is Access Point (not Access Point (WDS), unless you plan later to configure WDS, which is out of scope for this guide).
• Click the Wireless Security tab, and configure your key (the password when someone tried to connect to this wireless network).
• Leave all other options unchanged, and click Save.
Go back to the Network->Wifi, then click the Edit button for the second wifi interface. Make the same changes.
Once both wifi interfaces are configured, click Save and Apply. After a minute or two, the newly configured wireless networks should appear, i.e. searching for a wireless network on a computer or other device, the original GL-…. Wireless options should be gone, and the new wireless networks should be available.

1 Like

After giving up on this back in november I finally tried again last week and managed to set up the device in a way that is useful for me: WAN as a (typically unused rescue port), LAN1 with two VLANs, each one bridged to a WiFi network. I used the latest GL.inet release 2.27 (?) and not Openwrt 18.x