GL-E750 | Home WiFi as LAN?

It would be great to have the option to mark certain WiFi upstream networks in Repeater mode as “home” networks, tying those uplinks in as lan instead of the current wwan configuration. This would mean that the Mudi appears as a full value client on the local network, with DHCP disabled, and the same network settings (gateway, DHCP config, etc.) recasted from the host. It would be the equivalent of switching the Network Mode under More Settings from Router to either Access Point or Repeater.

Currently, the GL.inet web interface does not support this at all, and changing the configuration on LuCI will result in a config clash - network will be intermittently dropping off, and the GL.inet interface shows the Repeater mode as not configured. Trying to get it to recognise the interface again will reset the network the interface is attached to from lan to wwan.

I understand the security risks of this, however it would be a nice to have feature to be able to access the Mudi from my home network without adding extra firewall rules (I do not wish to have ports 80 and 22 continuously open to wwan and wan) without connecting to its own AP instead of my main WiFi network.

Seems this will make things complicated.

Two questions:

  1. Why you want to use Mudi as this purpose? It has a battery and should be used in a movable environment. If you use at fixed location you may consider our X750. Also if you change anything it may break Mudi’s integrated OLED display.

  2. Can you just do this in more settings->extender? This is so called bridge model or client mode.

I would only use it for this purpose at home - the goal being that at home, the device should act as if it was in a safe environment, allowing access from the uplink to SSH, the web interface, SAMBA shares, etc., while if I’m on the move, access should be limited to LAN only.

The only sensible way of doing this is to add the WiFi STA configuration specific to my WiFi to the lan network group. However even if I add it while keeping the wwan group, it is still first and foremost wwan, thus wwan rules apply to it (i.e. no external access). If I remove the wwan group, the GL.inet interface simply loses its mind saying the Extender configuration has been disabled.

I believe this is because the GL.inet interface doesn’t use a fixed reference to this STA interface, but rather tries to find the first STA WiFi uplink belonging to wwan. I think this could easily be fixed by slightly altering how the discovery happens.

I could, but that would set EVERY WiFi network I connect to, to extender/bridge mode, not just the home network.

When you set up extender/bridge mode, the router will not auto change the station it connect to. So it will not set every wifi network you connect to as extender. You need to set up one and keep the settings.

Before, we do have saved wifi networks and label them as wisp or extender. Then the router will auto connect and change mode. But that made a messs.

See, that’s a problem right there, because I am roaming between different WiFi APs during my usual day. This would mean that WiFi uplink only works at home, or that I need to continuously change the setting manually.