GL E750 Mudi not booting

My GL E750 does not boot anymore since a few days. It displays booting progress on LED up to about 80% and then stays there forever. No proposed reset does help. The behaviour is always the same: booting up up to 80% and then hanging. debricking with uboot was also not possible. Is there any possibility to monitor the boot up process or turn off some parts to boot up essential parts? or connect via some more low level terminal since ssh connection is not possible at current level of booting?

thx in advance

Maybe you can try reset MCU.

Already tried it and same result that starts booting and hangs at about 80%.

Is there no possibility to connect to device and monitor booting?

Have you tried to upgrade different firmware versions in the uboot?

I was not able to uboot even when i followed your instruction from here Debrick via Uboot - GL.iNet Docs with lan connection etc. How can i upgrade to a different firmware version?

I noticed some mistakes in the description of the document, and I have fed back to my colleagues.

First, Connect the router to the PC using a network cable.
Then set the IP address of the PC to, the netmask to, and the gateway to
Finally, repower the router and hold the reset button. About 10 seconds later, the screen will display uboot mode. You can upgrade the firmware by typing in your browser.

thx for new instructions. I will try them out as soon as I am back home next weekend.

1 Like


unfortunately still no sign of boot. Connected device like in the attached screenshot. anything wrong with my setup?

any help where my setup is wrong?


If the device doesn’t start after you update the firmware, contact after-sales service.