Gl-inet ddns doesn't work

I’m using my GL-MT300A with relayd, so I’m using a unique subnet with my main modem/router.

However, my problem is that I can’t use ddns. When I click on the DDNS link in the lower part of the admin page (, I can’t see anything. I tried to do a port forwanding on my GL-MT300A and also on my main router, but it hasn’t worked.

How can I get ddns working?

Thanks for a reply.

Here is a screenshot.

Your IP says connection refused. Maybe port forward doesn’t work in your main router.

If I enable upnp, does I also need to set a port forwarding?

You need to enable upnp in your main router. If the mini router reported that upnp is enabled and port is opened, then no need to set up port forwarder.

I have a main router which has local ip which is inaccessible to me because I need username and password, so only my Internet Provider can access it. There is only a second router which is in bridge.

I’ve already enabled upnp in the second router and in the GL-MT300A, but I can’t even know if upnp is enabled in my main router because I can’t access it.

Can this settings be enough or do I also have to enable upnp in the main router (perhaps asking my Internet Provider to do it for me)?

However, I have no problems with programs like utorrent, so I think maybe upnp is already enabled, isn’t it?

PS: I have attached my second router’s upnp settings.

Why don’t you have access to the main IPS router? Are you piggy-backing of a neighbours or something?