GL iNet Flint Issues with Alexa cutting out

I noticed that when Im using the flint router and im playing music with Alexa, it is cutting out.

If I switch back to the ISP supplied router then I have no problems.

What could be causing this?

Can you explain? The Alexa disconnect from the router or?

I dont think it disconnects, Though I havent tried a continuous ping.

When I play a radio station, the audio will cut out for a few seconds.

If I play songs via Spotify then I dont have this issue.

If i use another router then I dont have any issue.

But I know for sure the router is the problem.

@simonli can you pls try

Which radio station did you play with this issue?
I tried mine on “Pop Culture Radio” without problems.

I’ve tried it with RadioX, BBC R1 and Viking FM

My router was using the beta FW at the time.

Which firmware are you using? The latest 4.1 firmware will be released in two days, you can download tan try it.
Meanwhile, I will test these radio stations tonight.

I cant remember which beta it was but i’m taking it back to stable FW at the moment and i’ll test it tonight when I go home on the stable.

Please refer to this docs instruction to upgrade 4.1 firmware, we have released the stable version.


it still says its in beta release?

I updated flint yesterday and stuck it back in at home after a factory reset.

Currently not running any of the advert blocking etc but havent really had chance to further test alexa at the moment.

I have been having the same issues GL -AP1300LTE. Sometimes only one speaker plays. Sometimes none play and sometimes it will play for 30 seconds and then cut out and go to white noise. If I hook up to my old crappy Franklin T-10 hotspot or Netgear MR1100 it works fine. I have even reset the speakers and even changed Wi-Fi names to see and still the same issues.

It is hard to debug Alexa devices, because the do not provide any useful log. I have hat issues to display my photos, even if I allow every Amazon related Domain in PiHole … Some day it just works again, without any change for weeks.

But I would advice to use an open DNS in your network, for testing. Try (cloudflare) or (Google) for example.

Somewhere I’ve read, the DNS have to be the same as the gateway. In my experiences this works better when the uplink in the router is pointing to one of the DNS from above.