GL-iNet Slate does not connecto Unifi APs


I bought the Slate for my travels with the family.
I tried the Slate for the first time at my home WiFi network which is built of several Unifi AccessPoints in different rooms of my house. They all use the same SSID which is broadcasting through 2.4 GHz as well as 5 Ghz. Roaming and band steering is activated. I have never experienced any problems with any device with this configuration - until I tried it wth Slate.
The Slate will not connect to my home network no matter how often I try. I tried to manually connect through 2.4GHz or 5 Ghz,no chance. Onyl when I modify my home network so that I have sperate SSIDs for 2.4 and 5 Ghz it works. This is not what I want.
Especially I fear now that some hotel or a camping site also uses Unifi hardware and a mesh 2.4 and 5 GHz network and that I will not be able to connect.

Any ideas or suggestions to my problem?

Thanks in advance for every hint!

If you just got the Slate, make sure you have the latest released firmware, version 3.212. I and some others had some issues with earlier 3.2xx firmware on our AR750s connecting to some APs.

There is no difference if you connect to 2,4GHz or 5GHz besides range and bandwidth

Your device should perform as your laptop you use to connect to your mesh…

Under advanced settings in luci you can choose by yourself what band you try to connect to via wifi…

Which Unifi AP model(s) do you have? Do you have either WPA3 or WPA2/WPA3 security on the SSIDs? If so, then PMF (Protected Management Frames) may prevent connection by some devices.

I do not work for and I do not have formal association with GL.iNet

I use four different AccessPoints from Unifi:


Interesting information: If I disable “Band steering” in the Unifi Controller settings the problems described above are gone. This is surprising because the Slate is the only device I found that seem to have problems with the band steering to 5 GHz.

1 Like

Can you check in Slate luci you can enable 802.11kvr feature? Not sure if it works but better try.