GL-MiFi in Malta

Hi,

Bought a MiFi for the holidays. Bought a data package from Swiss Mobile. Tried to setup the Mifi.

blank stare as Malta is not listed. DUH???

Supposedly, these are the carriers and their APNs as my google-fu could find out.

Videophone (APN Connect)
go mobile (APN gointernet)
melita (APN web.melita)

I here for a few more days. Is there a quick solution? I’m really angry right now…

Edit: And for Swiss Mobile, I’d have to set APN “chili” on the go mobile network, as that seems to be the one they partner with.

What firmware version are you on?

2.271, it‘s supposed to be the newest one.

Try the new v3, it is still in beta but i use it every day, stable.

http://download.gl-inet.com/firmware/mifi/testing/

Wow, this looks just awesome. Very slick interface!

Funny thing happening. The MiFi finds “Play” as the carrier, which I presume is the naive one of the Swiss Mobile SIM. But it does not find the Go Mobile which they partner with here in Malta. Seems like gl-inet got rid of the country selection, but in the process made it impossible to have such special roaming card.
Is it possible that my assessment is correct? Or did I just make an ass out myself and I did something wrong?

Actually the carrier info is read directly from the modem. Doesn’t work?

Can you modify manually?

Oh, the maestro himself, wow.

I did a factory reset, still nothing.
Side Note: There seems no option in the ‘easy’ GUI to change the LAN Ip address from the 192.168.8.0/24 default, right?

The use-case of the https://www.swiss.com/ch/en/book/swiss-choice/swiss-mobile SIM card is that you connect to their partner network in any country, but don’t use the partner network’s APN, but the SwissMobile one (“chili”).

Only once I saw the modem finding “Play” as the carrier, but that is not one of the Maltese carriers, but the native carrier of the SIM. Obviously not of much use in this use case. And all the other times, I don’t see any network info in the GUI. Setting the APN and PIN does not let the modem connect.

How do I set the carrier manually?

Yeah you can change the routher IP from the GL UI.

https://docs.gl-inet.com/en/3/setup/lan_ip/

If you SSH into the router, you can write some commands:

uqmi -d /dev/cdc-wdm0 --start-network APN --autoconnect

Replace APN with your apn in the command above. Then run this:

uqmi -d /dev/cdc-wdm0 --get-data-status

You should see “connected”.