GL-MiFi Mini PCIe Problems


#1

I recently purchased a GL-MiFi (options: with battery, without a cell module). I want to put my own module in that works with the Sprint carrier in the US (none of the GL.iNet modules supported the bands necessary). I have a good amount of experience with OpenWRT and cellular modems, so I assumed this would be easy.

The jist of my problem is that any Mini PCIe modem I put in the GL-MiFi results in “No Modem device found. Plug in your USB modem to start.”. I can use these modems in a USB to Mini PCIe adapter with the GL-MiFi, but the internal Mini PCIe socket seems dead.

The longer explanation of my problem:
I wanted to use an MC7455 modem in the GL-MiFi (to use on the Sprint carrier). When I put the MC7455 in the GL-MiFi’s internal Mini PCIe socket, the firmware doesn’t detect it (“No Modem device found. Plug in your USB modem to start.”). I have checked dmesg and there is nothing in there indicating the modem is enumerated.
If I put the MC7455 in a USB Mini PCIe holder, it works with the GL-MiFi. This tells me the software and the modem are both good.

I also tried a SIM7100a Mini PCIe modem in the same way as the MC7455. I get the same results (internal socket doesn’t work, USB holder does work). Again, the modem and the software are good.

I have tried a few different firmware builds (stable and testing) as well as OpenWRT 18.06.1 (with the MBIM, QMI and sierra kernel modules installed) and all of them have the same problem.

The only conclusion I can come to is the Mini PCIe port inside my GL-MiFi doesn’t work. Is there some trick to get the Mini PCIe socket to work, or is there a chance my GL-MiFi is defective?


#2

MC7455 is usb 3.0. Use tape and mask 6 pin, see

https://cdn.techship.com/uploads/images/834/mc7455.1523022913.jpg


#3

MC7455 is usb 3.0. Use tape and mask 6 pin

I gave that a try, still no dice on the MC7455. The SIM7100a doesn’t have USB3 so I didn’t test it on that one.

I’m looking in to the “w_disable” pin 20 and reset pin on 22 to see if those might be tied low for some reason?


#4

No dice on the pin20/22 thing. I think even if the modem is ‘disabled’ it should still enumerate on USB.

Poked around a bit more, the VCC rail is only putting out about 1.17v. Nowhere near the 3.3v nominal needed by the card. Sounds like it might be a bad power supply?