Gl MiFi (V2.1) can not join network

For some reason my new Gl MiFi stopped being able to join to an wireless AP.

Basically I do a scan, and get it to connect to one of my many AP’s here.
It will save fine, but it will never connect to it (tested with open and closed AP’s).
The signal indicator will also stay on 0%

I’ve reset the GL MiFi several times to it’s original settings, but no luck.
This used to work perfect!

Any clue what could be causing this

If you want to try to salvage this, try one or both of the following:

  • Advanced=>Luci=>Networking=>Wifi=> delete the STAtion(s) (NOT THE AP it's perspective, your STAtion is connecting to an(other) AP, not the one the MIFI is broadcasting)
  • Reset the device holding the reset button in for at least 10 seconds. This will wipe all config.
A better solution, which will also wipe your config, is to upgrade to the just released 2.22. It has some much improved Station Management functions which I have just been testing.

Thank you for your reply.

I know how to connect to an AP with the MiFI, and this used to work perfect.
I have also reset the MiFI several times, but still no luck.

I’ve also just flashed the new 2.22, but again still no luck. The signal indicator (under Wireless Overview in Luci) stays on 0%, and no coneection is being made with the AP.

I’ve got no clue what could have caused this :-/

Is it open connection without password?

In firmware 2.22, can you reset the firmware and have an another try. I don’t know what is wrong but seems there should be a simple reason.

I’ve tried connecting to AP’s with password, and AP’s without. Unfortunately no luck…
I will do another reset and try again.

Will report back.

Hmmm it must have been some kind of ID 10 T error (read IDIOT), but it’s working again!

Not sure if the way I connected (after many resets) made a difference.

I now connected by using the “GL.Inet > WAN settings > Repeater” option.
Before this I always used the “Advanced settings > Network > Wifi” option to make a connection.

Anyway… It’s working again.