GL-MT1300 bandwidth issues when in repeater mode

i am on FW 3.203 and I am not using any VPN client. I have two separate networks this connects to. I’ve tried on both 2.4 and 5Ghz and while 5Ghz was a hair faster (a few mbps), it’s still nowhere near where it should be. One WAN source is my house wifi and one is my phone hotspot. I was doing some bandwidth testing and noticed I get about 1mbps up and 15mbps down when using either device as the supplied WAN. The devices I am using to test speed (my laptop) is right on top of the MT1300 so that isn’t an issue. if I connect a laptop (also tried my phone to ensure laptop wasn’t doing something weird) directly to either of those two networks that I are supplying the MT1300s WAN I’m at 25mbps down for my phone hotspot and about 45mbps from my home network so bandwidth supplied to the MT1300 is good. I did install and ran a bandwidth test directly from the MT1300 and it’s better but not great (12.5mbps down and 22 up). I’ll include that data below. I did some research here about some unchecked “Use builtin IPv6-management” to resolve this speed issue and i tried it but i already had the IPv6 toggle off so I figured that wouldn’t matter and it didn’t. I’m not sure what else I can do here but any suggestions would be appreciated.

Download: 12.57 Mbps
*** Latency: [in msec, 58 pings, 0.00% packet loss]***
*** Min: 10.810***
*** 10pct: 14.326***
*** Median: 23.909***
*** Avg: 46.963***
*** 90pct: 93.156***
*** Max: 330.503***
*** CPU Load: [in % busy (avg +/- std dev), 58 samples]***
*** cpu0: 24.8 +/- 10.7***
*** cpu1: 10.4 +/- 8.1***
*** cpu2: 7.4 +/- 7.6***
*** cpu3: 8.0 +/- 8.6***
*** Overhead: [in % used of total CPU available]***
*** netperf: 2.7***

*** Upload: 22.02 Mbps***
*** Latency: [in msec, 60 pings, 0.00% packet loss]***
*** Min: 17.338***
*** 10pct: 26.321***
*** Median: 43.302***
*** Avg: 53.660***
*** 90pct: 83.272***
*** Max: 210.547***
*** CPU Load: [in % busy (avg +/- std dev), 58 samples]***
*** cpu0: 32.2 +/- 9.8***
*** cpu1: 9.4 +/- 8.1***
*** cpu2: 7.9 +/- 7.7***
*** cpu3: 8.3 +/- 7.9***
*** Overhead: [in % used of total CPU available]***
*** netperf: 1.6***

ra0 RTWIFI SoftAP ESSID:“GL-MT1300-669-5G”
Mode:Managed Channel=149 Access Point: 94:83:C4:0F:16:6C
Bit Rate=867 Mb/s

root@GL-MT1300:~# iwconfig rax0
Mode:Managed Channel=1 Access Point: 94:83:C4:0F:16:6B
Bit Rate=144 Mb/s

Seems this is duplicated post. I replied you in another post.