GL-MT1300 (Beryl) dropping WIFI connection

Hi y’all,

Could you guys please fix the WIFI bug on GL-MT1300? I’ve bought one off Amazon, and the WIFI keeps disconnecting no matter what my settings are. This issue is well known within the Beryl’s community. My current workaround’s disabling WIFI and using another router as AP.

Appreciate any feedback.

We do receive feedback about MT1300 wifi dropping.

But still investigating in what situation this happens. Can you give more details of the set up?

I have spent so much time trying to deal with the connection dropping issues and I don’t see any updates that solve it. I have worked with support showing the consistent internal logs showing the problem and read others having similar issues.

Looks like there will not be any resolution and I’m left with finding a new product.

Suggestions on other mobile routers that I should consider to replace the Beryl?

I have a new firmware, updated wifi driver. Can you try?

My Beryl wifi works great. I have it setup as my main wifi router. Serves 10+ devices and traffic from my home lab, which is a Brume.

OP, should probably return it and get a replacement. Sounds like a faulty unit.

Same issues, maybe worse now. Connection drops, if I connect to my source mobile router no problem, but when through Beryl which is Ethernet cable connected to source it drops every few minutes.

1 Like

This was true for me on B4, but stopped with B5.

I’ve just bought one so when it turns up if there’s a problem I’ll find it. I’ll even figure out how to brick it if I don’t fix it…

Has there been any solution for this? I’ve been experiencing this as well, including with the latest beta firmware.

Have you tried turning off ‘Auto scan and re-connect’ in repeater options?

Pls open new thread with details, e.g. log. Thanks.

I’m having this same issue

Hi @alzhao

Any news on the firmware?
Started getting queries from my clients that the router is dropping wifi.

I only have 5G enabled and Wireguard VPN client for their routers. Also only one device is connected.


Can you try the snapshot now?

Hey @alzhao

This was directed to me?
What do you mean by snapshot?

I do not work for and I do not have formal association with GL.iNet

1 Like

@wcs2228 Thanks mate!
I’ll try. Will do it through GoodCloud since I don’t have physical access to the device.
Hope that works.

Same here, random disconnects from a normally reliable network… here is my kluge workaround til’ I find another router. Too bad, I like the Beryl otherwise. Connecting to network (captive) via PB wifi adapter, then sharing thru Ethernet to Beryl WAN port… works 24/7. Regards, G7