GL-MT1300 / Beryl Wi-Fi issues

After upgrading to 4.3.10 wi-fi stopped working.
Here is the log:

Mon Feb 12 00:59:19 2024 daemon.notice hostapd: wlan0: ACS-COMPLETED freq=2412 channel=1
Mon Feb 12 00:59:19 2024 daemon.notice hostapd: wlan0: interface state ACS->HT_SCAN
Mon Feb 12 00:59:20 2024 daemon.notice hostapd: 20/40 MHz operation not permitted on channel pri=1 sec=5 based on overlapping BSSes
Mon Feb 12 00:59:20 2024 daemon.notice hostapd: Fallback to 20 MHz
Mon Feb 12 00:59:20 2024 kern.info kernel: [  102.607855] br-lan: port 3(wlan0) entered blocking state
Mon Feb 12 00:59:20 2024 kern.info kernel: [  102.613252] br-lan: port 3(wlan0) entered forwarding state
Mon Feb 12 00:59:20 2024 daemon.notice hostapd: wlan0: interface state HT_SCAN->ENABLED
Mon Feb 12 00:59:20 2024 daemon.notice hostapd: wlan0: AP-ENABLED
Mon Feb 12 00:59:25 2024 daemon.notice netifd: Wireless device 'radio1' is now down
Mon Feb 12 00:59:47 2024 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1) --> new PHY
Mon Feb 12 00:59:50 2024 daemon.notice Tor[4119]: Bootstrapped 61% (loading_descriptors): Loading relay descriptors
Mon Feb 12 00:59:51 2024 daemon.notice Tor[4119]: Bootstrapped 66% (loading_descriptors): Loading relay descriptors
Mon Feb 12 00:59:55 2024 daemon.notice Tor[4119]: Bootstrapped 75% (enough_dirinfo): Loaded enough directory info to build circuits
Mon Feb 12 00:59:57 2024 daemon.notice netifd: radio1 (8560): Command failed: ubus call hostapd config_add {"iface":"wlan1", "config":"/var/run/hostapd-phy1.conf"} (Request timed out)
Mon Feb 12 00:59:57 2024 daemon.notice netifd: radio1 (8560): Device setup failed: HOSTAPD_START_FAILED
Mon Feb 12 00:59:57 2024 daemon.notice netifd: Wireless device 'radio1' set retry=0
Mon Feb 12 00:59:57 2024 daemon.crit netifd: Wireless device 'radio1' setup failed, retry=0
Mon Feb 12 00:59:57 2024 daemon.notice netifd: Wireless device 'radio1' is now down
Mon Feb 12 01:00:07 2024 daemon.err hostapd: Could not set interface wlan1 flags (UP): Operation timed out
Mon Feb 12 01:00:07 2024 daemon.err hostapd: nl80211: Could not set interface 'wlan1' UP
Mon Feb 12 01:00:07 2024 daemon.notice hostapd: nl80211: deinit ifname=wlan1 disabled_11b_rates=0
Mon Feb 12 01:00:07 2024 daemon.err hostapd: nl80211 driver initialization failed.
Mon Feb 12 01:00:07 2024 daemon.notice hostapd: wlan1: CTRL-EVENT-TERMINATING
Mon Feb 12 01:00:07 2024 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan1 wasn't started

What is the solution to this problem?

It might be helpfull if you could post the contents of /etc/config/wireless and /etc/config/network since i read its only affected on interface wlan1 it might be a configuration issue, but it can also easily be something else :wink:, did you by chance upgrade with the keep settings option?

It is possible the version of openwrt was swapped for a other private sdk which invalidates the wifi config.

1 Like

Thank for your reply.
Firmware was installed from scratch using uboot.
Here is /etc/config/wireless:


config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '2g'
	option country 'US'
	option disabled '0'
	option channel 'auto'
	option htmode 'HT40'
	option legacy_rates '0'
	option vendor_vht '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'GL-MT1300-173'
	option encryption 'psk2'
	option key 'goodlife'
	option wds '1'
	option isolate '0'
	option ifname 'wlan0'
	option disabled '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
	option band '5g'
	option htmode 'VHT80'
	option channels '36,40,44,48'
	option country 'US'
	option disabled '0'
	option channel 'auto'
	option legacy_rates '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'GL-MT1300-173-5G'
	option encryption 'psk2'
	option key 'goodlife'
	option wds '1'
	option isolate '0'
	option ifname 'wlan1'
	option disabled '0'

config wifi-iface 'guest2g'
	option device 'radio0'
	option network 'guest'
	option mode 'ap'
	option ifname 'wlan0-1'
	option encryption 'psk2'
	option key 'goodlife'
	option ssid 'GL-MT1300-173-Guest'
	option guest '1'
	option disabled '1'
	option wds '1'
	option isolate '1'

config wifi-iface 'guest5g'
	option device 'radio1'
	option network 'guest'
	option mode 'ap'
	option ifname 'wlan1-1'
	option encryption 'psk2'
	option key 'goodlife'
	option ssid 'GL-MT1300-173-5G-Guest'
	option guest '1'
	option disabled '1'
	option wds '1'
	option isolate '1'

and /etc/config/network:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd59:8156:9fd7::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option isolate '0'
	option ipaddr '10.33.33.7'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option force_link '0'
	option ipv6 '0'
	option metric '10'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname '@wan'
	option disabled '1'

config interface 'tethering6'
	option ifname '@tethering'
	option proto 'dhcpv6'
	option disabled '1'

config interface 'wwan6'
	option ifname '@wwan'
	option proto 'dhcpv6'
	option disabled '1'

config interface 'guest'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.9.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option multicast_querier '1'
	option igmp_snooping '0'
	option isolate '0'
	option bridge_empty '1'
	option disabled '1'

config interface 'wwan'
	option proto 'dhcp'

config interface 'modem_1_1_2_6'
	option ifname '@modem_1_1_2'
	option proto 'dhcpv6'
	option disabled '1'

config rule 'policy_direct_rt'
	option lookup 'main'
	option suppress_prefixlength '0'
	option priority '1100'

config rule 'policy_default_rt_vpn'
	option mark '0x8000/0xc000'
	option lookup '8000'
	option priority '1101'
	option invert '1'

config rule6 'policy_direct_rt6'
	option lookup 'main'
	option suppress_prefixlength '0'
	option priority '1100'

config rule6 'policy_default_rt_vpn6'
	option mark '0x8000/0xc000'
	option lookup '8000'
	option priority '1101'
	option invert '1'

I wonder if this is valid ^, this is not a uci list, so it needs to be one value i think or auto, and i think it needs to be called channel.

This can be accepted, although a little strange start ip :wink:

can you check if it changes something if you use one channel there?

If not im also interested to see output of:

iw wlan1 info just so to know what hostapd reports.

I would go with a factory reset.

Login via SSH:

firstboot
reboot

I wonder if this is valid ^, this is not a uci list, so it needs to be one value i think or auto, and i think it needs to be called channel .

Changed to channel ‘40’ - no result

option ipaddr ‘10.33.33.7’

Yeah, I’ve modified it, to avoid ip conflicts within network (I have a several routers in one network)

iw wlan1 info` just so to know what hostapd reports.

Here it is:

Interface wlan1
	ifindex 10
	wdev 0x100000002
	addr 94:83:c4:0e:b1:76
	ssid GL-MT1300-173-5G
	type AP
	wiphy 1
	channel 36 (5180 MHz), width: 80 MHz, center1: 5210 MHz
	txpower 23.00 dBm
	multicast TXQ:
		qsz-byt	qsz-pkt	flows	drops	marks	overlmt	hashcol	tx-bytes	tx-packets
		0	0	0	0	0	0	0	0		0

Looks like hardware is alive, but in fact - it’s not working.
Also “Wireless” section is stuck in the Gl-Inet Admin Panel…

I’ve made installation from uboot, without saving a previous configuration.
Also made a resets few times.
Wifi is visible upon restarting after hard reset, but in 20-30 secs router goes down and restart again…

Maybe try to reinstall again?
I would go with the beta: GL.iNet download center

Tried now with beta - no luck :frowning:

Hmm yup i think this might be related to your issue :wink:

Because if you use subnet mask of 255.255.255.0 and two dhcp servers in the same range it will conflict, you have two options here:

  1. The easy one:
    You can turn off the dhcp and turn the interface into a dhcp client, or a different range.

  2. You can also do the more advanced one:
    You use two different subnet masks, this is really technical :wink:

Here you can check the link

It’s not related to IP configuration…
Currently router is out of the network and plugged-in to PC using LAN cable.
No WI-FI after hard reset, firmware reinstall using uboot and etc.

P.S. all worked perfectly before with old IP configuration, issue with wlan started after software upgrade.

Hmm that sound no good.

Does the wifi work with very basic settings from gl ui?

Because if it is the privated SDK like mediateks, the options for wireless are extremely limited for OpenWrt system, and i mean that it listens very sensitive to settings and when it finds something what it doesn’t know APs and such won’t work or you get dummy AP’s.

And maybe the firmware is not good.

Currently wifi doesn’t works at all.

The only thing I can see, is that you use channel 36 with 80MHz bandwidth. Channel 36 is used for 20 MHz BW.
Channel 42 is used for 80 MHz BW (EU/DE).
Edit: corrected BW for channel 36