GL-MT1300 / Beryl: Wireguard Internet Killswitch broken?

Hi everybody,
I want to build a wireguard tunnel to my parents house, but keep the internet breakout local e.g. to keep low latency for gaming and high bandwidth for downloads. AllowedIP: (Wireguard server is within this range). This works perfectly on my smartphone - I can reach all devices at my parents LAN and I am still using my local internet breakout.
When I copy the same config file to Beryl and turn on VPN, I can reach all devices at my parents LAN, but cannot access the internet anymore. Neither local, nor through the tunnel (which makes sense). It looks like the Internet Killswitch option on duty, although it’s not enabled. It doesn’t make a difference, if the option is enabled or disabled - it’s always the same result, no internet.

Do you have any ideas?

Best regards

Set Alloweds IP

Thanks for your answer, but it doesn’t work either. As I already mentioned - same config on smartphone works. In the meantime I tested it with my notebook and it worked as well. With Beryl (FW version 3.200) it does not work, so I suggest the error must have something to do with this system.

This problem has nothing to do with the killswitch.

It should be the subnet setup.

You set the allowed IP to, pls note, the router itself is also in this range.

So you may need to change the router IP to 172.16 or 10.0 domain, pls avoid conflict with the wireguard IP

As a test, I changed the remote LAN subnet and Wireguard server to the range. Again smartphone, notebook etc. are working (internet: local breakout; remote LAN reachable) - same config on Beryl does not work as expected (remote LAN reachable, but no internet access).
Please believe me that it has nothing to do with the AllowedIPs config, because it works like a charm on other devices.

You should not use this subnet as well, because it is used by the wireguard backbone.

1 Like