GL-MT1300 cannot load GL iNet web gui with v4.3.11 using nginx full

I installed the firmware v4.3.11 which is based on OpenWrt 22.03.4. I then went ahead and replaced nginx.

Removed nginx-ssl and replaced it with the full blown nginx-all-module and nginx-mod-luci-ssl.

This resulted in breaking the GL iNet web gui. Luci works but the native one doesnt. I enter directly the the URLs https://internal-ip/#/ and https://internal-ip/#/internet and it redirects to the luci interface.

I have done the same thing in previous firmware based on v21 OpenWRT (with GL-MT2500) and this this has worked in the past without issues. It seems to manifest in later firmware

Any help appreciated.

Also interestingly I was not able to go back. I attempted to uninstall the full blown nginx but I could not find in the list the original nginx-ssl.

Guess you need to find the issues by going through the config and check if everything (like the base nginx config) is still the same.

Is there a crucial key setting to facilitate serving of the web gui pages ?

If there is one, is there uci command for it ?

I guess you destroyed the nginx config, so you need to check this at first. Not sure what exactly you did - but obviously it wasn’t the right thing. :sweat_smile:

The old configs should be within /rom/etc/nginx

It seems that the full blown nginx (nginx-all-module) may not be compatible. The steps I executed are literaly the ones I stated in the post. No manual modifications were added. The process includes uninstall one and reinstall the other ones.

Upon review it seems that the installation truncates a whole bunch of stuff.

  1. All conf references for gli are no longer available.
    /etc/nginx/conf.d/gl.conf and few includes are gone.
    /etc/nginx/gl-conf.d/.

  2. All references to lua are also truncated. This includes all files under
    /usr/share/gl-ngx/.

I wonder if any of this is compatible or even tested.

Problem now is that I cannot go back to original state cause the initial package of nginx-ssl is no longer showing in the list of available packages. So I think unless I figure out the conf changes that are needed (which may or may not work due to differences between the nginx versions - uci based configs) I will have to restore the whole thing to original state.’

Wonder if anyone has tested this path as well and can confirm that it will work after configuration effort.

I would simply copy all files from /rom/etc/nginx/ to /etc/nginx and restart nginx.
The worst that could happen is that it still does not work. In that case some reset might be the best way.

Nginx is not managed by uci.

I think its bricked. there are dependencies on lua that have been trashed.

Where would one be able to find some hidden packages that show as “unknown” when they are installed and when uninstalled you cannot find them. The following are some packages that have been uninstalled and cannot be found now in the software/package list.

nginx-ssl
gl-sdk4-repeater
gl-sdk4-luci

just to name a few.

Are they hiding somewhere in the device or getting downloaded in real time ?
Is there a partition in the device that has those packages stored ?

Just reset the device to restore all packages.