GL-MT1300 Firmware update to 3.203 - Wifi no longer working

Hi,

As per the topic title, I’ve just updated the routers firmware to the 3.203 version. Both Wifi frequencies are enabled but neither is transmitting an SSID for connection.

I’m guessing this is something you’ll want to fix before this firmware version is a general release.

Thx

Also, within the 5G band settings there was an error when trying to change the TX Power, I didn’t try to change the 2.4G TX settings.

Password changes, worked however.

Worked now or not?

Are you using this firmware https://dl.gl-inet.com/firmware/snapshots/3.203_beta5/mt1300/

Hi, No I used the one listed on your release page:

openwrt-mt1300-3.203-0701.bin

This was a known issue that has been fixed?

Seems WiFi settings were messed up when upgrade.

The latest firmware has some improvement in WiFi driver.

Not sure related to your issue though.

Ok, thx. I’ll give it a test at some point and let you know.

How long is the warranty on these devices?

Can confirm this firmware breaks wireless - I recovered using Uboot before seeing if I could gain access via LAN cable.

Hi, Yes this is the version which broke the wireless and related settings. LAN access appeared to be fine.

Did you test the later betas mentioned above?

I’m having no issues with 3.203 Beta4 on my Beryl.

I tried 3.203-0722 and -809 (beta5) and both have problems remembering the time and “sync with browser” doesn’t work either (time can be synced via Luci).
Otherwise, seems OK.

Can you let me know what is your browser?

I checked and I can sync the timezone.

When you sync, there is nothing happen? Do you have a screen record?

This is what I got just now with a fresh flash of 3.203-0809 (beta5) on a Beryl.
Browser is Firefox.

First screenshot is what I get after setting the language and navigating to “more settings > time zone”
Second one is when I click “sync”
Third one shows actual time on my computer.

time1

time2

time3

I wonder if Time Zone|Sync only syncs the time zone. On my page it shows that router time and browser time don’t match because my router is set to UTC while my browser is US-East. The UTC time itself is correct, and the warning goes away if I manually change the time zone or sync, either. (Beta 4 here).

But you are days off. I wonder if your NTP is working? If you go into Luci, does it show that the NTP client is enabled, and the servers are the openwrt.pool.ntp.org servers?

Yes and yes. Time sync worked in Luci but this might be because I’d already connected to the internet by then (necessary to download and install Luci)

The screen shots are from before you connected to the Internet? That date of Monday August 9 is pretty close to the build time of Beta5.

1 Like

This is something new for my Beryl. On Beta4, I had no difficulty using it in repeater mode. I have then tried it with the ethernet connection, and then the wifi was disconnecting every 10 seconds or so. The trigger was being logged as apcli losing the connection. That surprises me, because I thought AP CLIent was part of the repeater.

However, I tried with Beta5, (build 8-09) and this problem no longer occured.

Beta5 has upgraded wifi driver. We are testing stability.

I have GL-S1300 Convexa-S and just installed the latest version (V3.203).
After that update, my mobiles cannot connect to wifi, and I had to revert back to the older version (V3.105) in order to get it functional again.

Dear all,

the technical support is writing that a new firmware will be available soon which should solve the mentioned problem! See the mail below.

From: “GL.iNet Technical Support” support@gl-inet.com
Date: 13 Jan 2022 09:14:56 +0100 (CET)
To: xxxxatxxxx
Subject: Re: After Update not able to connect anymore!?

Hi xxxx,

​Noted, we will release a new firmware these two days, could you please kindly wait it and have a try?

​I will also keep you noted in this email, many thanks.

Best Regards,
xxx xxx Technical Support
Website: …
Tel: +86-755-xxxx-xxxx


On Thu, 13 Jan at 6:52 AM , xxxx wrote:

Hi xxx

It wasn’t an update, I had to downgrade the firmware!

So I hope you developers can fix this issue soon and also that the wireless power can be adjusted again!

Best Regards,
xxxxxx

Although you marked some info, but pls do not post private emails, although the content does not matter this time.

If this is what it meant, firmware 3.211 was just released.