GL-MT1300 unable to connect - firmware re-installed

My GL-MT1300 was working perfectly until a few days ago. I have not touched it since setting up in December 2022.

There blue light bar on the front is constantly flashing on and off.

I can see and connect to the router via wifi on my iMac and iphone but if I try to connect to but I never connect.

I have tried different browsers, cleared cache etc.

I have tried to do a standard reset and a factory reset with no luck, the light on the front just keeps blinking.

I have followed the guide to re-install the firmware via UBOOT and have tried the two latest versions, 4.2.0 and 4.2.1 - I get the message saying firmware update successful, and have left the device for 15/20 mins before power off and trying to set up again, still no luck.

All I get, is the device flashing at me, unable to connect via ethernet or wifi.

I have the original power cable.

Can you offer any further advice on how to get this working again?
Thank you

Versions 4.2.0 and 4.2.1 are under development and are not very stable. It is recommended that you try the firmware version 3.216

Yes, it worked, thanks