Have issue not being able to change default WiFi password on the Beryl GL-MT1300.

Follow the procedure of Modify and get Success notification but password does not change.

Tried different browsers. Switching off and back on Wifi but WiFi signal fails to be restarted after toggling button.

Firmware V3.2

Any ideas, thanks?

1 Like

Still cannot change password?

Or turn does not turn on?

Yes still haven’t been able to get router to broadcast with a new WiFi password. However, the routers interface indicates that the password has changed and been accepted. But I still have to log on to WiFi with default password.

Tried to toggle off and on the WiFi signal but although the toggle button indicates WiFi switched back on it is not broadcasting. Only fixed by restarting the router.

Hope this makes sense.

I note that you don’t mention that you’ve tried a reset ?

Failing that I had this issue with a B1300 recently. Reloading firmware using uboot fixed it :frowning:

Do you have antivius in your pc?

For example bitdefender will prevent you inputting password on http (not https) website.

No not tried a reset as yet. Only unplugging and re restarting. Will try that next.

Have been putting off as its working behind a Captive Portal and had some issues getting it to connect at first. Trying to find convenient time to try in case have issues getting connected again.

Yes have anti virus on laptop but also tried on Pixel book with not anti virus with same result.

Then I have no idea. If reflashing the firmware does not work you can send back for analysis.