GL-MT3000 Beryl AX - No Country Code Option in Luci?

As title really, I have the GL-MT3000 Beryl AX, but there is no country code option in Luci that I actually change.

I tried to follow the directions here to change the code, but there just isn’t this option available under Luci’s Network→Wireless→Advanced Settings. I do not live in the US but received what seems to be a device intended for the US.

The current setting shows Country: 00 (in Luci).

I then SSH’d in and tried uci show wireless which shows:‘US’ and
wireless.mt798111.disabled=‘0’ and‘US’ and

I also tried 4.2.0 beta 4, stock and a snapshot firmware.

I will try alzhao’s instructions here GL-MT300N-V2 unable to be repeater for wifi network channel 13 to change the codes, but I do not know what chipset to write in the ‘uci set’ instructions? Do I write mt7981?

i.e. uci set‘XX’ etc? where XX = country code?

[EDIT]; I tried this with both mt798111 and mt798112, it didn’t complain i.e. seemed to accept it, but when I commiited and rebooted, it didn’t stick either? Still shows ‘00’ in Luci. Pretty frustrating.

I tried uci set‘JP’ based on these instructions here GL-AXT1800 Slate AX 5Ghz Channel - #4 by yuxin.zou but SSH just says “Invalid argument”?

I am not sure why they cannot be changed in the Luci interface?


Have you looked at this? Not sure if the same on the Beryl AX but worth checking:

Thanks @Almahadeus using that link I modified the wireless config to add the two regions 5 and 13 for 2.4 and 5G, but it’s still not showing up in Luci. I had to ADD these two “options” as they were not even there in the first place.

Not sure if it helps find networks any better, actually I have tracked the issue of networks down to using the GLiNet app on my iPhone 8 (finds networks to repeat very quickly) vs it just searching and never finding any on the iPAD Air 3 Glinet App. Both with DFS switch on.

1 Like

What Firmware are you running?

On latest Snapshot it is missing for GL-MT3000 Beryl AX but I have it in my Flints configuration. It would be under Device Configuration next to the General Settings tab.

In the Command Line you can do iw reg set

@alzhao already answered on another post

Hi thanks for having a go at answering these, much appreciated.

A1: 4.2.0 beta 4, but I tried the snapshot dated 19th as well. I did not try the stable F/W.

A2: Could you post a screecap please? I cannot find suuch a “General Settings” tab or setting in the Beryl AX Menu, either in the GliNet App, nor WebAdmin, nor in Luci. I did follow the details in the link I posted above (which is similar to your directions) to modify the Country Code from Luci namely:

" You can find this country setting in the web admin GUI (LuCi) unter → Menu: Network/Wireless < for GLiNET>
** click “Edit” on any of your Wi-Fi radios, then open the “Advanced Settings” tab - and there is the “Country Code” field.
** If you do not see any “Edit” button, then you have not yet configured any Wi-Fi radio configuration using “Add

A3. I’m sorry, I do not have sufficient technical knowledge on Router F/W to comment on OpenWRT commands, but I did read somewhere that whilst GLiNET base firwmare is very closely related to OpenWRT, it does deviate from it. I tried a few “iw” commands yeterday but they didn’t work very well. Using WinSCP to access the wireless file was much easier for me (and I did modify it).

Thank you for the heads up on that other post.


Got a (very fast) reply from GLiNet support email.

“Please do not use Luci to modify wifi settings because MT3000 use proprietary wifi driver and luci is not fully compatible”


1 Like

Is there a fix for this SERIOUS issue?

MT3000 doesn’t see any 5G channel above 64, and there seams to be no way to fix it…
Kind of useless as it is!
Please get a fix asap!
Thank you!

What country is it in?
DFS channels could be blocked.

You should post this as a new tech support issue and not add it to a post about country codes

Well, it’s actually about country codes:

  • GL-MT3000 by default is set to “00” (US), at least that’s what Luci shows
  • no way to change it, or is there?

Channels allowed in the country I am now:
2G: 1 2 3 4 5 6 7 8 9 10 11 12 13
5G: 36 40 44 48 52 56 60 64 100 104 108 112 116 120 124 128 132 136 140 149 153 157 161 165

Can’t connect to any wifi that uses: 100 104 108 112 116 120 124 128 132 136 140 149 153 157 161 165

Whats the firmware?
Do you have use DFS channels enabled under repeater settings?

There is a way to change the country code, GLiNet has advised not too because the driver is proprietary and will cause issues.

See this post Slate Plus Title Bar - #3 by michaelsage and the thread.

You can actually change the country code in etc/config/wireless.
What happens is the frequencies will change, but it will still show “US” in the top corner.


In my view, for the ordinary user who wants to use this Travel Router and change the frequencies on the fly, GLiNET absolutely need to make this change of country much easier, preferably in the GLiNET App (and in the WebAdmin); no user should have to delve into the etc/config/wireless file to change this, so as to comply with a specific country’s frequency limitations (or benefit from that country’s wider frequency range).


Pls do not use luci for MT3000 as Luci is not compatible.

For repeater, pls give details e.g.
how do you know it does not connect? Using luci (this does not work) or the original UI.
Enabled DFS?
system logs ?

On latest greatest nighty snapshot.

DFS enabled.

Using Wifi Explorer on a Mac , all APs on channels above 64 are not listed in router admin, under “Available Networks” in the “Join Wi-Fi” panel after clicking “Switch Network”

Re: “There is a way to change the country code”
Would be interested in how and what are the pitfalls.

Thank you!

For how, please read through my post in the link I provided above; the method is explained there.

Regarding pitfalls I can’t see any if it is done correctly; others with more knowledge than me might have some opinions. My only bugbear is that it can’t be easily done on the fly via the App.


Changing country in /etc/config/wireless DOES NOT WORK on the MT3000 (nor does changing macaddress…).

Did you restart services or the router after you changed it?

Yes of course…

Do you have a MT3000 and are you able to see and connect to 5G using channels above 64?
If yes, maybe I should try the same firmware as you and do the same config changes, do you mind sharing?

Thank you!

Btw, there is no iw on the MT3000.

I do have the MT3000 running on a snapshot from a weak ago It has connected to a xfinity Wireless on Channel 161 40Mhz. It did not want to connect 80Mhz wpa2-psk/wpa-sae(default for MT3000 is wpa2-psk)

BTW it seem to be working just fine