GL-MT300A 2.17 kmod-bluetooth broken

opkg install kmod-bluetooth

return postinstall error.

2.16 is no problem

I just tested. kmod-bluetooth depends on a lot of other modules. I am not sure why this happen.

Is the bluetooth module usable? Sometimes it returns postinst script errors but it still can be used.

I could not use the Bluetooth .

However , it seems to be another problem .

If I use the /dev/mmcblkp1, it does not work .

However , if I use the /dev/sda(same sdcard with reader), it will work .

Are there any difference between mmc and sda?

I am not quite understand your problem about mmcblkp1 and sda

mmc and sda are different in driver. The first one is mmc specific interface, the second is usb.

on MT300A, there is mmcblkp0, which will be used for the microsd card.

Here are two of the log.

extroot of mmc is segment fault occurs in bluetoothctl.

In sda it does not occur .

 

Can you tell me what bluetooth module are you using? Does it connect to the router via USB or UART?

bluetooth module is CSR via USB.

root@GL-MT300A:~# lsusb

Bus 001 Device 004: ID 058f:6366 Alcor Micro Corp. Multi Flash Reader

Bus 001 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 001 Device 002: ID 058f:6254 Alcor Micro Corp. USB Hub

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

root@GL-MT300A:~#

root@GL-MT300A:~# bluetoothctl

[NEW] Controller 00:09:DD:40:AD:3C BlueZ 5.33 [default]

[NEW] Device 5E:55:46:65:72:AE PRO3523

[bluetooth]#