GL-MT300A-36d restoring stock firmware problem

I am having a problem restoring the stock firmware on the above router. I had previously updated it to OpenWrt but as this was not a big success, I tried to restore the original firmware.
I can get to the upload firmware page after setting the local IP to and it uploads fine but it is not restoring the stock firmware from OpenWrt.
I have U-boot connected via FT232 and I can talk to it, but after restoring the firmware it seems to
automatically replace what I uploaded with the openWrt Luci that I am trying to get rid of.
I also tried to update this to the latest firmware which has the WireGuard VPN server/client and
when at home behind our home router it worked. I brought it back to work and it booted and
replaced this stock firmware with OpenWrt !
Clearly there is something I need to do with U-boot and the problem is repeated across two of these units. I need them to run as OpenVPN or wireguard servers and OpenWrt is too messy for clients to use.
Can someone tell me how I need to fix this - ? I am happy to use Uboot and prefer the quick fix as I have work to complete.

Seems that you are having a browser cache problem.

Just use a different browser, or use private browser tab, or clear browse cache will solve the problem.