GL-MT300A - routing to my internal network


I’ve bought a GL-MT300A to use a VPN hotspot so I can watch BBC iplayer outside the UK on my Fire TV boxes. I’m using the beta 2.20 firmware and it seems to be working fine so far. What I would like to do is for the FTV to view my media server that’s on my internal network. How do I setup either a route or a bridge to my internal network (192.168 range)



I am not quite sure about your setup. MT300A and fire TV box is with you outside UK and you want to connect to the media server at your home?

Then you need to set up port forwarding in your home router.

Sorry my fault, let me see if I can explain myself better:


My Fire TV box connects wirelessly to my MT300A, which in-turn is connected via copper to my home router. Using VPN the Fire TV connection is routed via tun0 and out to a UK VPN server. Currently the 300A is using its own DHCP server in the IP 192.168.8 range while the rest of my home network is on the 192.168.1 range.

What I would like to do is either have a static route to my home media server or some kind of bridge where the 300A and any device connected to it can see the 192.168.1 range and or my home media server.

Is this possible?


Thanks Paul

If you are using Ethernet cable, it will be very easy.

You just need to bridge wan and lan, then disable DHCP server of 300A. You can do this in LuCI.


Thanks for the update but can you give me some direction on what to do. All I can see is the deselection of Dnsmasq


Can anyone give instructions of how help with my issue.

@irishbiker, I found the problem. If you are using openvpn on GL-MT300A, you cannot use bridge mode. OpenVPN will not work in bridge mode.

Seems you want your FireTV can play videos from your media server and play via the VPN tun. It seems not possible in this setup.

OK - which hardware / software should I be looking at? do any of your models allow for bridging?

This should be possible with static routes, can you tell me how the MT300N is connected to your home router?

Is it via the LAN cable, or is the MT300N connected via the WAN port? Does the MT300N get a DHCP address from your home router?

Hi Justin

Its a 300A and yes I have connected it via a port on my router to the WAN port on my 300A. Also correct my router has supplied a DHCP address to the unit

Can something answer here?

I have the following situation and problem.

My Pc -> FritzBox -> GL Inet (with OpenVPN Connection) -> PC 2

MyPC has IP:

FritzBox has IP: and Subnet

GL Inet Router has IP from Static IP: Subnet

But PC 2 has IP


If I connect with Wlan to GL Inet i can acces with the PC2

But not over MyPC?


What settings must I configure?


@V4n1X, seems I don’t understand your question very well. Which box is with Internet connection? Which is DHCP server?


Okay, so my FritzBox is my DHCP Server my NTP Server and also creates a Cable (WAN) Connection to my ISP, the GL Inet AR300M is connected from it’s WAN Port to the Lan Port of the FritzBox.

You have the AR150 set as a router (router behind a router) and if you want to communicate from PC to PC2 you probably need to set up the AR300M as a “Dumb AP” so the PCs are on the same subnet.

The AR300M’s IP of is for the WAN port and assigned by the DHCP of the fritzbox (most likely) as the default config for the WAN on the AR300M is to get it’s DHCP address from the “ISP” which in this case it “thinks” is your Fritzbox (down stream DHCP server)

This is probably what you want [OpenWrt Wiki] Wireless Access Point / Dumb Access Point but I do not think you can do this in the GLi GUI and probably need to use the “Advanced” tab to get to Luci. (Networking=>LAN=Edit)

Basically you disable the LAN DHCP, set a static address in the 192.168.178.x range for the AR300M so you can connect to it (check you Fritzbox for it’s DHCP range and choose a number outside the range) and connect the cable LAN to LAN.

The problem is that V4n1X’s PC2 is connected to a VPN server via AR300M. All the traffic in PC2 is routed to the vpn server. So it cannot be access from pc.

If you have to do this, you have to configure AR300M’s firewall so that all traffic to 192.168.178.x is not routed to the vpn. It can be done using iptables I think.

Something like this post: linux - Output traffic on different interfaces based on destination port - Unix & Linux Stack Exchange

I am not sure the detailed iptables configuration but that has to be tried manually.

In order to let your “my pc” be able to access “pc2”, you also need to modify the firewall on AR300M to access data and forward in wan Interface.

A dump AP cannot do this because you need openvpn connection.