GL-MT300A wifi extremely slow

Hello,

I bought a GL-MT300A, installing LEDE using [OpenWrt Wiki] Techdata: GL.iNet GL-MT300A v1.3

I setup it as AP, connected by cable to my broadband router and clients connect using wifi to GL-MT300A. These clients (basically, my iPhone), when testing the download speed, I get 1637 kilobytes/second.

With the same configuration, using a Mikrotik RB751U-2HnD (a bit old, OpenWrt Barrier Breaker 14.07), I get 4645 kilobytes/second (3 times faster)

How is this possible? Am I missing something? Should I use a special wifi driver in LEDE? Any idea?

Thanks a lot.

 

 

What is the bandwidth of your Internet?

Seems both not fast. Even 4645KB/s is 37Mbps which is not fast.

MT300A can easily achieve 70 to 80 Mbps using the stock firmware.

Why you change it to LEDE? I head that in the recent LEDE firmware the MTK driver has some problems.

 

Hello alzhao, thanks for reply.

I updated to LEDE because I want to modify the system a lot (wpa2 enterpreise, captive portal, freeradius, database, payments, php…) and I want to have the last version of the operating system. I already have the system I want to create working in my old router.

My broadband is 50 megabits/s, so 37Mbps seems OK to me.

Anyway, you gave me an idea, I am going to restore to the original firmware and test speed to see what happens, and I will let you know.

Which one should I use?: GL.iNet download center (clean or v1) EDIT: Forget about this question, I saw it is explained in the user manual :slight_smile:

 

By the way, is it possible to use other drivers (probably, proprietary drivers) in LEDE for this WIFI adapter? Do you have any reference about what you told me about the drivers? (I will research anyway).

By the way, I realised that the wifi range is really good.

Thanks a lot.

 

This is interesting.

I restored the device to the original OS: GL.iNet download center

I tested the speed and it is also slow. I compared the /etc/config/wireless file with my mikrotik router and I only saw one difference, this line:

option htmode ‘HT20’

I added that line to the configuration, restarted, and voilà, now it is working 2x faster, at 3100 kilobytes/s, see attached screenshot. Although still not as fast as my mikrotik router.

I was more curious and I installed LEDE, again. I carried out the same test, and the same result, it is 2x faster.

Therefore my conclusion is that there is no problem with the wifi drivers in LEDE or in the original firmware, but probably wifi configuration must be improved.

Any clue about how should I setup properly wifi in this router? Thnaks a lot.

 

 

 

 

Hi Ricardo,

I think I can explain a bit the difference you experienced. First, HT20 refers to the channel width 20MHz in the 2.4GHz band.

As from your finding (either LEDE or GL.inet firmware) the default value for the MT300A is 40MHz because it is a technical requirement in order to operate in radio mode 300M which is theoretically the best mode. However if you live in an urban area with a lot of router activity, your WiFi will endure severe interference using a 40MHz-wide channel and diminish its performance.

In other words, the best suitable configuration for WiFi efficiency depends on the radiation environment in which your minirouter operates. In practice 40MHz is only useful in areas with few WiFi interference, otherwise it seems better to reduce the channel width to 20MHz.

That being said, if I should recommend you a configuration I will say stick using:
Channel width 20MHz ( option htmode ‘HT20’ )
Auto channel selection ( option channel ‘auto’ )
Use 2 streams for both transmit and receive antennas (as I don’t own a MT300A, I can’t tell which are the option values to set 2 Tx and 2 Rx streams)

Overall for a 802.11n minirouter with internal antennas, if you get above 50% of your ISP broadband speed it should be consider a good performance.