GL-MT300N on sale now

The problem is physically, one one antenna can be connected to the radio part, otherwise I have no idea how the signal will be affected.

So, if you want to use uFL connector, the internal antenna will not be connected. Otherwise you will have two antennas working at the same time.

So isn’t there a “switch”? i.e. a uFL like connector which when I connect external antenna, the internal antenna will be detected automatically?

The answer is YES. We have used this before. But it is not standard size. It is even smaller than the uFL connector. And the price is like gold… Even you don’t mind the price, you still cannot connect an ordinary external antenna to it because of the size.

Is small jumper pads possible to implement this?

Yes. I think so. But there will be extra components, taking extra space and having unknown influence to the signal.

How can I connect an external antenna to the standard version?

You can replace the probe connector with a uFL connector, but there requires good skills.

You can just take down the probe connector and solder the antenna to the board directly, which is easier.

You can buy one with external antenna.



Thanks for the lowdown Alfie.

I totally understand. It is not so easy to have the choice of either antenna, which is perfectly understandable.

Agree that extra jumper pads might have negative or at least unknown influences to the signal, those thoughts crossed my mind as well.

I guess we just have to order the internal or external antenna version whenever either is required. No issue.

Pulling off the probe connector and soldering in the antenna directly, without bothering to fit a male u.FL connector, seems like a viable solution actually…

I guess the main issue here was that we were confused because the probe connector looks almost identical to a u.FL connector to a layman i.e. at first glance.



Yes, JW, these technical things looks crazy. Why not perfect!

I agree that this is a conspiracy: the IT industry wants consumers to pay more…

Other things include: internet speed is Mbps, but consumers always think in Mbyte , storage capacity in MB is actually by 1000, not 1024 …

Well, no problem, I’ll just have to buy a second one when it’s available :smiley: I’d prefer the connector because soldering directly without a thru-hole will put strain on the copper and probably tear it off the PCB after a couple of open-closes of the case

I have been able to go from using a wired WAN to WiFi as the WAN interface using the native GUI by using Repeater mode. I cannot figure out how to go back to a wired WAN interface except by going back to factory state. Can someone help me figure out a more elegant way to do this? I’d prefer not to use LuCi or the CLI but am open to doing that if unavoidable.

Can the reset switch be used to go back to factory state?

Also, does this device implement OpenWRT’s failsafe mode? If so, how does one invoke it?


I don’t know whether it is exactly the failsafe mod eof OpenWRT, but when you press the reset button for more then 10 seconds the router will get back to its factory defaults settings but keep the current installed firmware version intact.

I don’t have any experience with a WiFi WAN and I don’t have a situation in which I wil need WiFi WAN, so I can’t tell you easily the best way to switch between WiFi WAN and ethernet WAN.

I was able to confirm that holding down reset gets one back to factory state. Failsafe mode is when you’ve somehow messed up the firmware and it lets you reinstall the firmware.

The ability to switch between wired and wireless WAN is very useful while traveling, hence my interest.

Yes, there is failsafe mode bit not well implemented.

If you have connected to the console via UART, you can invoke it by pressing ‘f’ then enter when the boot message told you to do.

Or you can keep pressing and releasing the reset button around 10 seconds after the rooter boots. Unfortunately there is no LED indications and I cannot ssh/telnet to the device via So this is not very useful.


[question about tracking deleted] - I see my mt300n is on its way in the Account info section - Thanks :slight_smile:


I love the specs of this travel router. I’m just wondering if the router is capable of running WISP with (stock) OpenWrt. With previous routers, Asus WL330gE and Asus WL330N3G (both very nice devices), I cannot do WISP with OpenWrt.

Can someone tell me whenever wisp is possible with stock OpenWrt on a GL-MT300N?

GL-MT300N (and GL-iNet6416) can act as a ‘Universal Repeater’ both a wireless client and an AP simultaneously, however they only have a single radio. Using a single radio means the AP frequency gets locked to whatever the client AP frequency is and you also get lower throughput.

IMHO the biggest limitation is that the radio cannot act as an AP while scanning for new client APs to connect to and (with regular config) cant start the AP if the wireless client isn’t connected (as it doesn’t know what freq to use). This might be a good thing in some situations, and you can always use ethernet to reconfigure it, but I like to be able to manage the device via wifi.

A simple fix is to add a second radio using a usb dongle (I use a $4 RT5370 adapter). This provides a second radio so you can use one radio as a wireless client and the other can be used as an independent AP.


That sounds very promising since not needing a wired connection can be very useful when things go south on the road. And this is the first explanation I’ve read of why my laptop won’t connect if the WISP parameters are to an AP that no longer exists in the vicinity!

Could you provide guidance for how to set something like that up? I suspect it cannot be configured from the GUI but could be wrong.

And are you using an adapter with an external antenna?


You might need to use cli to add drivers if you add a usb wireless adapter - depends on the model. Either way all the WISP configuration can be done via Luci web interface: Network > Wifi although its not as straight forward as other router web interfaces. BTW I noticed I sometimes get higher throughput if I use the single internal radio for both client wireless and AP even though they are locked on the same frequency. Not sure why this is - I may change my config to use the usb radio only for admin access. My usb adapter does not have an external arial.


Interesting about the performance drop. Could be a poor USB implementation.

I have a USB wifi dongle somewhere that I can try to find to experiment with since having a wireless admin interface at all times is useful. (Hopefully the additional power draw is small). Otherwise, there is always the brute force approach of using two travel routers connected over Ethernet!

P.S. I used to have a Tenda travel router that always broadcast a SSID regardless of whether it could connect to a wireless AP on the WAN side. I wonder what I did with it.

I don’t know how Tenda router did that. If there is a deep modification of the wireless driver, this could be possible.

Maybe a script that just disable the sta mode when it is not available is an easier way.

Not sure how they did it but it was a unique feature!

Regarding the MT300N, I’ve been able to get it into WISP mode by using the simplified GUI but can’t figure out how to get it back to being a wireless router with a wired WAN short of doing a factory reset. Any help will be greatly appreciated.

Once I’m comfortable with that, I will work on getting OpenVPN client installed which is why I bought it in the first place :slight_smile:

If you are using our WebUI, you could just change the configuration back to DHCP and bring the wired WAn back.

I could have sworn I tried that previously and failed but I did it again a few minutes ago and it works! Is the WebUI documented somewhere?

If I fool around with the settings in LuCi and mess something up, will your WebUI bring sanity back if I can reach it? (Say while I am trying to get OpenVPN running). Or would I have to do a factory reset at that point?

Just download backups of your configs using Luci then you can restore to whatever state you want. BTW you can also do all the OpenVPN config via luci as well. The problem I encountered was that for OpenVPN to work you need to set up the firewall to route all data over the VPN and this sticks even if you disable OpenVPN via luci. This prevents you from just logging into a hotel’s captive portal then activating OpenVPN, so I connect using a Repeater config then switch to my OpenVPN config. Maybe someday the GL-iNet web gui might have a wizard to simplify things like this :wink:


Unfortunately, except for a simple instructions send with the device, we didn’t have docs for the UI. This is something we should do but really short of hand who can write good English.

If you fool around the network settings, you can bring it back with our UI. But if you set something in firewall etc., our UI may not be able to aware it. At that time you need to revert to “factory settings” and start over.

@Craig, for use in hotel and activation of the captive portal, seems we need to setup two SSID to achieve this. One ssid connect you to openvpn and the other one didn’t. If you are using GL-Ar150, you can turn on/off openvpn temporarily using the switch.