GL-MT300N-V2 Cannot Activate Wireguard Client

I have a GL-MT300N-V2 (Mango) running firmware version 4.3.6. I’m hosting a Wireguard server at home using a wg-easy container running on my virtualizaion server. I can connect to it just fine from my laptops and my cell phone.

I created a new config for my GL-MT300N-V2 and manually entered it as a new Wireguard client configuration. When I activate the Wireguard client, it just sits trying to establish a connection to the server. If I bring up the Wireguard log, I see the following lines:

Thu Jul 20 15:06:48 2023 daemon.notice netifd: Interface 'wgclient' is setting up now
Thu Jul 20 15:06:48 2023 daemon.notice netifd: wgclient (315): Error: inet6 prefix is expected rather than "".

I can ping my server’s DNS name just fine from the LuCI interface’s diagnostics.

Is there a setting that I’m missing in my client config? It looks like it’s expecting some sort of IPv6 setting field in the config, but I have no idea what that could be.

Yeah, it looks like it’s choking on IPv6. Can you edit the VM WG server & Mango’s WG Client confs to ensureIPv4, accordingly?

Personally I disable IPv6 across my network; I don’t care for the inherent risk of leaks. That might clear things up too.

I disabled IPv6 on the VM and made sure it was also disabled in the Docker container. I also went into the GL-MT300N-V2’s shell and made sure that IPv6 was disabled completely there, along with removing the IPv6 interfaces in LuCI. I tried starting the Wireguard client up and got the same exact error.

This is what my Wireguard client config looks like:

PrivateKey = [private key]
Address =

PublicKey = [public key]
PresharedKey = [psk]
AllowedIPs =, ::/0
PersistentKeepalive = 0
Endpoint = [fqdn of my server]:[port]

I’ve tried removing the IPv6 allowed IP and that did not change anything.

Are you using yesterdays B2?

If you roll back to 3.216, does it work?

If you used a /32 mask?

That’s a good question; apologies I missed it. Firmware 3.216 is the latest stable release for the Mango. I’d make sure that’s the case on your device. Beta is beta for a reason, after all.

Here’s a ‘known good’ WG Server using a Flint (AX1800, f/w 4.2.1-release5) to a WG Client of a Certa (AR750, f/w 3.216). The Certa’s difference between your Mango is really just the difference of the Wi-Fi-AC radio. This config is as simple as it gets. I’m confident you can template from it as you need:

I rolled back to firmware 3.216 and tried again, and now it’s connecting to my WireGuard VPN just fine. I believe that fully disabling IPv6 on the VM hosting the WireGuard server was what fixed the issue.

Thank you for all of the help!

On a lark I updated my Mango to 4.3.6b2, and my wireguard client connected just fine. I don’t have v4 in the mix on the server side.

Impressed with everything they got into 4.3.6, luci too!