GL-MT300N-V2 Can't connect to Sky router

I’ve just purchased a GL-MT300N-V2 so I can keep the same software test setup when working on 2 different sites.

On the first site I have wired and wireless connections with a router / gateway at

On the second site I have a Sky wireless router (and Sky multi-room set top boxes) with a router / gateway at I also use a VPN on my Windows laptop to access some servers at the other site. The 2 networks being at the same address provides a level of complication when using the VPN - unfortunately I am unable to change either network, hence the reason to purchase this travel router.

My test kit is a Windows laptop (wireless LAN only) with a Linux Virtual Machine and an embedded Linux PC with wired Ethernet only. It would be convenient if the network addresses remain stable as I mount the embedded PCs filesystem on the VM, and nfs doesn’t like mount points disappearing.

The GL-MT300N-V2 connects to both the wired and wireless networks on the first site, but fails to connect to the Sky router on the second site (Repeater mode). To test if there was some interaction between the WAN and LAN WIFI, I have used a USB3 to wired Ethernet converter to connect to the GL-MT300N-V2’s LAN socket, turned off the WIFI connection (LAN side) and still cannot connect.

The network SSID of the second site is shown but the connection always times out.

Has anyone else had success connecting to a Sky Router?

I’m wondering if the addition of Sky’s multi-room system (which forms a set of wifi repeaters) is consuming the channels the WAN WIFI uses.

The other option is range … but the SSID shows up as full strength and I’m only 8-10m away from the main router and <2m from the nearest of the multi-room boxes. Is this range too far for the GL-MT300N-V2?

Can you make a simple topology?

I initially connected via WiFi to set the router up.

The first thing I did was to select repeater mode, scan for WiFi signals and try to connect to the network. It appears to time out (either reports ‘Error: timed out’ or just changes the connect button from a grey spinning logo back to ‘connect’) each time I try.

I have also connected via the wired lan socket, turned off the lan WiFi, selected repeater mode, scanned for WiFi and tried to connect - this has also failed.

I’ve not tried anything complex yet, that description was to show my intended use. The spec appears to support that, but I’m struggling with the first stage.

1 Like