GL-MT300N-V2-cf9 - Slow speed using PIA VPN

I’m using my own installed VPN (Private Internet Access) on my computer with the travel modem and experiencing a serious drop in speed. Is there a fix to this?

Should I opt for the VPNs in GL.iNet instead?
Thanks for the help.

I think you are using OpenVPN, not the WireGuard.
If you can get the WireGuard config of PIA, setup on GL-MT300N-V2, it will much faster than OpenVPN.

I don’t how to get the WireGuard config. Maybe you can ask their support.
There is a discussion about it.

Thanks for your response. I’m only using my computer-installed VPN client (PIA) and not the VPNs in GL.iNet as I assumed this would be a redundancy. Is that true? Should I be using the internal VPN if I’m already using an external client?

On another note, inside the settings for the PIA client I am able to choose between OpenVPN and WireGuard so I switched it to WireGuard. Perhaps that will do the trick.