GL-MT300N-V2 - Firmware 3.102 Cloudflare problem

Hi, I have problem setting “Custom DNS Server” → “DNS over TLS” → “Claudflare”.

Is impossible to set “Claudflare” because after the page reload il alwais set “NextDNS”

How I can set “Claudflare”.

Chers R.

To confirm go to dnsleaktest site.

Refresh the browser cache?

Oops, this is a bug.

Will fix and resend the firmware.


The screenshot above confused me because I don’t see the “Select DNS Server” dropdown at all after just reflahing 3.102, and in 3.104 the option is actually called DNS over TLS with Cloudflare.

Was NextDNS permanently removed from the GUI options? (I know that it can still be configured manually with stubby, etc – just curious)

Next DNS requires openssl 1.1 to work. So we removed from current version and will add it in all openwrt 1907 or openssl 1.1. firmware.

1 Like