GL-MT300N-V2 firmware update confusion


I just bought a GL-MT300N-V2 and it came with firmware 2.26 and I set it up OK, I then wanted to upgrade it to 2.264 but it wouldn’t download from within the web gui so I went to the download section of the git and flashed “lede-mt300n-v2-clean-2.264” and now the interface is very very different and I can’t find the Open VPN section at all.

Where can I get the default firmware flash file from?


Read this:

than click here:

Yep, seen all that.

I tried a third time and must have bricked it as I couldn’t get it to do anything after the last flash. I then tried the Uboot approach with a serial to USB lead and Putty but I always got garbled text from the router even though the baud rate was set to 115200.

I then read down to the bottom of the page and found the Web UI for the boot and flash … ARGHHH! why wasn’t this at the top of the page???

I then flashed, with the WEB UI uboot, the same 2.264 bin file I tried earlier (in your link) and then it worked and was at the latest firmware, all is now well.