GL-MT300N-V2 FW3.105 Repeater Mode Bug?

Hi there - I’ve just bought a Mango V2 off of the back of some of the great reviews I’ve seen and I’ve got to say, I’m very impressed with this little box and everything it can do.

The issue I’ve come across is that there seems to be a bug when in repeater mode.

For my use case, I am connecting a non-wifi enabled device to the wifi by using the Mango as a repeater. The AP is switched off and I only use the Ethernet ports.

This all works as long as you first manually connect the Mango to the wifi (and even this takes a few attempts before it successfully does so) every time it reboots.

It seems to be an existing problem from last year:
GL-MT300N-V2-ec6 won't connect to WiFi in repeater mode

Is there any fix/workaround that doesn’t require me to enable the AP or requires me to manually reconnect it every time the system is restarted? It’s a headless device in a hard to reach location so it’s a real hassle to connect a monitor up to re-establish the wifi connection.

Is anyone else using the Mango in router mode having this problem?

Can you stop the repeater manager?

ssh to the router and do

/etc/init.d/gl_health stop
/etc/init.d/gl_health disable