GL-MT300N-V2 not working

I bought one of these last year, had issues with it working over WiFi so put it to one side.

I have just tried to use it again, but it is not showing the router in Wireless Connections and I cant access it with a Lan cable, except when I hold down the reset button when plugging the power cable in and flashing the firmware which is working.

I managed to hold down the reset button and reset the firmware using uboot to V3.102 and after this did not work I tried V3.025 (https://docs.gl-inet.com/en/3/release_notes/gl-mt300n-v2/). I have tried this using a 1A, 2A and 3A eternal PSU and two LAN cables. I know the LAN cables and power adaptors are good as it is allowing me to flash the firmware with them.

When booting the GL-MT300N-V2 and checking wireless networks I am not seeing the GL-MT300N-V2 SSID show, but I am also only getting one power light show on the GL-MT300N-V2. According to the manual another WiFi light should show, but it is not showing. I also tried pressing the reset button seeing this can be used to turn wireless off and on, but this did not help.

I have also tried to connect using a LAN cable (plugged in LAN and then tried WAN on the GL-MT300N-V2) and connecting to http://192.168.8.1/ fails.

What seems to be happening is the GL-MT300N-V2 will have a solid power light for a while, then it will blink once. The laptop will then loose a network connection and reconnect again. It seems like it is stuck in a booting loop, failing to boot and rebooting itself.

I also tried holding the reset button on the GL-MT300N-V2 for 10 seconds to reset it, but this did not help.

As a last resort I just tried flashing it to firmware V3.011 and have tried it with a ethernet cable plugged in and with no ethernet cable plugged in. The power light comes on, and then flashes for fast for three seconds then flashes slower for about 12 seconds, then remains solid for about 20 seconds, and then repeats this loop. Its like its stuck in a booting loop and reseting itself and seems to be doing this with all firmwares, yet is able to reset the firmwares using uboot.

If the unit has become totally faulty, I have now had it too long to return it to the shop I bought it from for a refund or replacement, even though I have not been using it.

If you have used uboot to flash the correct firmware, e.g. 3.104 from https://dl.gl-inet.com/firmware/mt300n-v2/testing/

If it does not work, it should be faulty.

I suggest that you send cs at gl-inet.com a email, citing this post and ask for a replacement.