GL-MT300N-v2 very slow openvpn server

Hi All

I’m new in gl-inet router
i bought a MT300N-v2 router to act as vpn server at my home , so that i can access my home network outside of my home.

here is my home network speed , DL 300 UL 50 mbps

remote 800 DL , 300 UL mbps

but when connect to vpn , routed all the internet traffic through VPN , max speed getting 2-3mbps up/down only .

if not routed internet traffic , accessing the VPN site NAS or etc also speed around 2-3mbps …
Checked both site traffic is not busy , also both side router cpu is not busy , the MT300N max cpu also at 25% only …

anyone facing this kind of issue ?

i’m expecting at least the limit will me cap at the VPN site upload , which is 50mbps

Can you use wireguard?

is there a limitation for openvpn ?

Openvpn on this mini router can only achieve several Mbps and that is normal. 2-3Mbps seems low but 5-6Mbps will be max in server mode I think.

Using wireguard you can go 10 times more than that.

what’s the bottleneck in the case of openvpn using in this small router ?
the ram looks fine , the cpu usage looks fine… what else could be the bottleneck ?

by the way , i just tested the wireguard … it seem getting the same result … , which is 2-3mbps only …
any reason

Maybe this is something else.

Openvpn use a lot of cpu power.

that’s what i thought , but checking on the CPU usage , it barely over 25%… as this is just use at vpn server only … my main router not supporting VPN function , therefore just getting this MT300N to act as VPN server. i’m connecting my main router LAN to WAN interface of MT300N, then port forwarding from main router to the MT300N WAN interface.
as my main purpose is accessing the main router LAN which is WAN ip for MT300N.
initially try to set this MT300N just use as LAN with VPN server feature , but apparently in order to activate the VPN server , it must detect the present of WAN interface , for some reason , the VPN server is bind to WAN interface rather than the LAN interface on the MT300N .

any setting that i could have done it wrong ? why the speed is cap at 2-3mbps only .
and it is the same result for wireguard .

Can you try changing the cipher?

after tuning … finally … the speed is making sense , openVPN getting around 8mbps , wireguard getting around 30mbps … i guess that’s how at least the MT300N should perform .