GL-MT300N Wired Bridge?

Here is my setup: I have my main router downstairs and my mini router (GL-MT300N) upstairs. My MT300N is connected to the main router via powerline adapter (in other words, it is a wired connection); the powerline adapter’s Ethernet cable upstairs is plugged into the WAN port on the MT300N. With this setup, everything works great - I plug in the MT300N, it receives an internet signal from the router downstairs via powerline adapter connection, and the wifi signal the MT300N broadcasts is very strong for devices to connect to upstairs, internet is working, etc. However, this upstairs wifi signal broadcast by the MT300N is on its own network - when devices connect to this SSID, they can only see each other, they cannot see the devices connected to the main router downstairs and over the rest of the house. Thus, the wifi signal generated from my MT300N does not extend to my main network. I would like for the MT300N’s wifi signal to be part of the main network so that devices and apps utilized upstairs (Plex, Roku, Audio Chromecast, etc.) are part of the whole house network.

As such, I would like to understand how to bridge this wifi signal from the MT300N back to the main network, but I want to keep the connection between the main router and the MT300N wired. Yes, my main router downstairs broadcasts a wifi signal, but it is too weak to effectively use upstairs, and I don’t want to use a wireless repeater. I have successfully set-up a wireless repeater upstairs and it is MUCH slower than my current setup of broadcasting a new wireless signal from the MT300N whereby the MT300N is receiving its input via wired connection to the main router from powerline adapter. I don’t want to grab the wifi signal downstairs and repeat it upstairs, I want to grab the WIRED signal upstairs coming out of the powerline adapter and into the MT300N and somehow bridge this back to the main router’s network so that the wifi signal broadcast by the MT300N is on the original network.

Is this possible?

I think this is almost the default operation of a “virgin” OpenWrt router. If you head over to their forum/Wiki you will surely find the answer.

You’ll need to use Luci or even edit the config files directly,

Perhaps something like this: Bridged AP [Old OpenWrt Wiki]

There is a load of reading under recipies: Recipes [Old OpenWrt Wiki]


Thanks very much for the quick response, Glitch. I’ve read the link you posted for the OpenWRT Bridged AP and in my limited understanding it does appear to be exactly what I am looking for. I am a newbie at this so I have a couple follow-up questions that I am hopeful someone can answer:

  1. Is the MT300N already an OpenWRT router or do I have to somehow re-configure it to be one in order to setup the “OpenWRT Bridged AP” as described in Glitch’s link? In other words, do I need to follow some sort of reset procedure, then upload a different firmware to the MT300N first or do I just need to edit the existing “/etc/config/network” and “/etc/config/wireless” config files?

  2. Glitch had written:

“You’ll need to use Luci or even edit the config files directly.”

Question 2a: 2. How do I edit the config files directly from within the MT300N’s web configuration utility?

Question 2b: What is “Luci?” Is this something specific to the MT300N or is it related to OpenWRT? Is the default web configuration utility for the MT300N already “Luci” or do I need to do something to change it to “Luci?”

>>Question 2a: 2. How do I edit the config files directly from within the MT300N’s web configuration utility?
You can’t - I use WinSCP (free).

>>Question 2b: What is “Luci?” Is this something specific to the MT300N or is it related to OpenWRT?
Luci (I call it Lucy but I’m sure the “geeks” call it Loochi) is the GUI for OpenWrt (and DDWrt, IIRC).


The stock firmware is basically OpenWrt with an additional GUI, except it now has OpenVPN built in.
To get to Luci (from the GL GUI) click “advanced settings” at the top right of the screen.

I’m thinking this might be the way to go:

  1. set up you internet in the Gl GUI (first option under settings) - you want “cable > DHCP”.

  2. Go into Luci and try this:
    Secure and Turn on Wifi [Old OpenWrt Wiki]

Otherwise you’ll have to wait for Alzhao!


@glitch, thanks for the great answers.

@Endeavour47, to achieve the bridge, you can refer to this post:

It is long. I copy the useful info here:

1. Download two script and compile in your firmware. They are:

The first file is to switch between router and AP bridge mode. It should be /usr/bin/switch_mode

The 2nd file is script assigned to the hardware switch. It should be rename /etc/rc.button/BTN_1

So, when you change the switch to the left, it is router mode, when you move the switch to the right, it is bridge mode.

DO NOT forget to change the two files to executable by using “chmod +x”

Do you know how to put this scripts to the correct place in the router? You can use winscp if you are in windows.


Alternative solution is to click the “Advanced Settings” in the up-right corner of the UI and login Luci.

  1. Then go to Network->Interfaces
  2. delete WAN and WAN6
  3. Edit LAN, go to "Physical Settings". You should see "eth0.1" is checked. check VLAN Interface: "eth0.2" as well
  4. Go to bottom of this page and find DHCP section. Check Disable DHCP for this interface.
  5. Then click "Save and Apply".
  6. Your network will break. Connect it back in around 10 seconds and you will find your device will get IP from your main router. You will not be able to access the mini router any more because you don't know its IP address any more.
If you can I suggest you use the firmware method. As you can control the router using the switch and come back for settings.

I actually think that there is an easier way to do this. If you are running via Ethernet cable, then you can configure the Gli deivce as a wired “Dumb AP” using this Dumb AP How To. The Luci config is real easy. Start with a clean device and backup your default config.

The device will NOT work as a router if you take it out of this config. You would need to restore the above backup. It’s possible to use the switch to change between 2 configs, but that’s advanced functionality.

Thank you very much Glitch, alzhao, and RangerZ for all your input. It was all quite helpful and an excellent learning experience for me. I tried all three methods –

Method 1: Uploading two scripts via winscp:

I taught myself how to use winscp and logged into the router successfully using ‘root’ as username, with regular password and scp as file protocol, found the respective directories (/usr/bin/ and /etc/rc.button/), uploaded the scripts (switch_mode and BTN_1) into their respective directories, and in each case then went into the command line while in the respective directory and ran the chmod +x command to make the files executable.

I could not get this method to work. I think perhaps I wasn’t using issuing the chmod +x command correctly because nothing seemed to change at all in the behavior of the MT300N. Even if I moved the physical switch to the right, the MT300N stayed the same and still allowed me to log into it at and it was not bridging to my main router’s network. I rebooted the router, checked that the scripts were indeed there via winscp (they were, and were check marked executable), but nothing changed. Internet worked, but I was not bridged to my main router’s network.

Method 2: Using Advanced Settings (Luci) to accomplish the same as Method 1 but with no physical switch:

This method worked perfectly! I went into Luci, followed alzhao’s instructions, and 10 seconds later I was receiving internet and could see my main network. The wifi signal from the MT300N is strong and is definitely bridging back to the main router via the Ethernet connection between the two routers. All apps and devices upstairs on the new SSID are seeing the main network flawlessly. Mission accomplished. (Though, as expected, I can no longer log into the MT300N.)

Method 3 – Using Luci, configure Dumb AP via steps on

I could not get this method to work. Using Luci, I followed the steps and set an IP for the MT300N right next to my main router’s IP, then disabled DHCP, then disabled Firewall. But this simply broke the MT300N and broke all internet. The help doc said that I would be able to re-access the MT300N via the new IP I had specified for it, but this did not work. Not sure what I did wrong here.

In particular, I would like to still try and get Method 1 to work. All is working perfect now with Method 2, but it would be a nice elegant solution if I had a physical switch to switch the MT300N between regular router operation and AP/Bridge. That way, I could log back into the MT300N anytime I wanted by simply moving the switch to the left. I suspect I messed up the ‘chmod +x’ command because it just seemed like the new scripts weren’t executing.

Any suggestions/thoughts on getting Method 1 to work?

I just reread the article and it’s not crystal clear that you need to connect the Ethernet Cable to the LAN port, not the WAN port. If you use the WAN port you would not be able to login.

@Endeavour47, I need to recheck the script. The process is too complicated for beginners. Need to have this in the UI.

@RangerZ - Thanks for the follow-up. I’m pretty sure that for Method 3 (Dumb AP) I had the Ethernet cable connected to the LAN port versus the WAN port, but at some point I will reset the router and try again just to make sure.

@alzaho - Thanks for the follow-up. That would be awesome if the ability to set-up a Bridge/AP via the physical switch (Method 1) was configurable via the regular UI. For now I’ve got Method 2 working like a charm (changing settings in Luci to set-up the bridge), but I will look forward to a possible UI functionality for setting up Method 1.

Thank you!

Has this been made possible in the GUI? I need to switch to AP mode. Really like the idea of using this but if not I will have to return and get another device.

Now in the firmware you can set up the switch button to change from router to AP.

Thank you for your assistance here. can you tell me which specific firmware for GL-MT300n-v2 has this feature to select router or ap using the button switch? i have loaded 3.025 and also 3.100-1217 and neither have this option in the button setting. it only allows “none” or select from one of the vpn options (wireguard, open vpn, tor).

hi, I think you need to try v2.272

From firmware v3.x we removed this because it is not frequently used.

ok thanks- to me that does not make sense, why purposefully remove functionality from a product, and then still have the hardware switch? also this was one of the selling features which led me to purchase it. i mean we are talking about something you already built and had installed in the product, and there are obviously multiple requests for the feature- so why not leave it? it only makes for a more versatile product.

p.s. maybe it is seldom used… because it is not there! :wink:

thanks is very useful. I see that in method 2 you can define and ip in lan interface of your network rang and then you can enter on the Gui interface using that ip.
interfaces lan
general set up
static address
and then you can define
ip and gateway.