GL-MV1000 brume vanilla openwrt support

they don’t look like uboot imgages.
glinet_gl-mv1000-ext4-sdcard.img.gz
glinet_gl-mv1000-initramfs-kernel.bin
glinet_gl-mv1000-squashfs-sdcard.img.gz

question?
does sdcard means the first partition in the micro sd reader or the ubuntu partition

I found flashing instructions: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=050c24f05c85268431515fb118a0710941473f2c
I got it working, I extracted the image from glinet_gl-mv1000-squashfs-sdcard.img.gz and uploaded with uboot.

1 Like

what driver to enable network on the usb-c port?

I know the network file should have usb0 like below

config interface ‘lan’
option type ‘bridge’
option ifname ‘lan0 lan1 usb0’

USB-C port is connecting to USB gadget interface. So you need to install RNDIS driver.

yeah I installed kmod-usb-net-rndis but that did not work.
kmod-usb-gadget-eth not showing up in package list for snapshot.

It’s not that simple.

you need this three patches from the original gl-inet github commit (https://github.com/gl-inet/openwrt/commit/b2ef49741602b306b910c77288edda8dc059031f)

540-arm64-add-udc-driver.patch

541-arm64-usb-device-dts.patch

542-arm64-usb-gadget-ether-fix-mac.patch

(for kernel 4.19 you should rename them to 547…, 548…, 549 for example)

Copy them to target/linux/mvebu/patches-4.14/ or target/linux/mvebu/patches-4.19/ (should work for both kernel versions)

then

make kernel_menuconfig

and the patches should apply.

Afterwards you can go to device drivers - usb - usb gadget support - usb periphal controller and select " Marvell USB2.0 Device Controller" and “Marvell Armada 38X/3700/8K USB 3.0 controller”

save the config and

make

thank you. I just wish I knew what I was doing at making the build environment, adding the patches, the make kernel_menuconfig and everything after that because that is all above my skills base. I’ve tried walking myself through it only to end up wasting my time with failure.

just wondering how this is coming along with the new 19.07.3. I truely would like to be able to install something that is not snapshot on my brume.

I built a 19.07.3 brume vanilla image yesterday and also added the drivers for my dwa-171 wifi dongle , working much better than the openwrt snapshots.

2 Likes

thank you marcz I flashed via uboot but not response via ssh or http on 192.168.1.1 and no dhcp server. boots to a solid power light but that’s all.

did you unplug the cable to renew dhcp lease?

yes and unplugeed power cable too and since I was flashing image static 192.168.1.2 used for client should have been ok too I guess. I did come from 3.104 adguard version. nor/nand issue. this box is different from the other devices i’m used.

I flashed from the glinet web ui without problem.

false alarm working now. not sure why but happy. thanks!

1 Like

Ok , I’m glad it worked.

would love to give some feed back on your sharing but please don’t take this negatively. just posting so others who choose to try out your build know what else is built in.

adblock, okay with 500mb of storage use in emmc use it or leave it space is not an isue.
nextdns, I like it and use it but noticed when you uninstall it there is still residual traffic from the router to nexdns.io and since it’s built it cant’ be removed.
ttyd, gives me the creeps :wink:
openvpn, yes
vpnbyepass, I use vpn-policy-routing and love it. my deal breaker since I can’t uninstall and you cant have both installed.

Following your suggestions I built an image with only luci, all packages installed are in the .manifest.

1 Like

been using image for a while now works great. the one thing I could never get working was my dlink dwa-171.
I installed
kmod-rtl-8812au-ct
kmod-rtlwifi
kmod-rtlwifi-usb

I then removed kmod-rt-8812au-ct and tried the alternate driver of
kmod-8xxxu without luck also.

“iwconfig” does not yield a wlan0, and I have tried deleting /etc/config/wireless. and I can’t see it with lsusb
any ideas greatly appreciated.

For the dlink dwa-171 I have installed kmod-rtl8812au-ct hostapd-common wpad-openssl , after setup the WiFi a reboot is needed to work properly.

1 Like

Let me first say this may not be the place for this questions since it is about vanilla openwrt but does hold some merrit since it’s on an mv1000. So I decided I may be interested in using ttyd. I flashed your patches with minimal plugins but now I want to get ttyd working. I install luci-app-ttyd and enabled with defaults and tried configuring with no luck. in your first mv1000 image ttyd worked perfect straight from flash

  1. did you add a modified config file to your image? (/etc/config/ttyd)
  2. the default port is 7681, if connected via the web page does this port need access to it extenally by opening port 7681 or is it all done from within the web interface scripting. also I am only using https.

any pointers greatly appreciated.