GL-SF1200 and IPv6

Hi,
From a clean firmware 3.215 install,
I’m enabling IPv6 on both my GL-iNet devices: a GL-AR300M and a GL-SF1200.

To activate IPv6,

  1. Create an executable file /etc/sysctl.d/99-enable-ipv6.conf with proper parameters
  2. Make /etc/sysctl.d/99-disable-ipv6.conf non-executable
  3. Reboot the device

Actually, I do so by copying and pasting the existing file and changing the value from the original:

cp /etc/sysctl.d/99-disable-ipv6.conf /etc/sysctl.d/99-enable-ipv6.conf
chmod -x /etc/sysctl.d/99-enable-ipv6.conf
nano /etc/sysctl.d/99-enable-ipv6.conf

Change the value as below:

net.ipv6.conf.all.disable_ipv6=0
net.ipv6.conf.lo.disable_ipv6=0
net.ipv6.conf.default.disable_ipv6=0

Extract of /etc/config/network for lan and lan6 on GL-SF1200:

config interface 'lan'
        option type 'bridge'
        option netmask '255.255.255.0'
        option hostname 'GL-SF1200'
        option ipaddr '192.168.0.50'
        option macaddr 'XX:XX:XX:XX:XX:XX'
        option proto 'dhcp'
        option igmp_snooping '1'
        option multicast_to_unicast '0'
        option ifname 'eth0.1 eth0.2'

config interface 'lan6'
        option proto 'dhcpv6'
        option ifname '@lan'
        option reqaddress 'try'
        option reqprefix 'no'

IPv6 works fine on my GL-AR300M. However, my GL-SF1200 doesn’t grab any global IPv6 address from the same DHCP server.

Have you got ideas how to dig deeper in this issue?