GL-SF1200 not connecting to EAP network

Just purchased GL-SF1200 and noticed even though it displays EAP wifi networks when attempting to connect with username and password it wont let me connect. When trying to manually confiure the network the drop down menu is missing 802.1x EAP/WPA and 802.1x EAP/WPA2 options.

Is there a way of adding this functionality or the hardware is simply not capable of doing so. The router was updated to the latest firmware.

Thanks.

Sorry it just does not support EAP.

Would you know which models support EAP? I cant find a list of devices or the info in the specs for different models.

Thanks.

This was the only list i saw which led me to believe SF1200 supported EAP.

https://docs.gl-inet.com/en/3/tutorials/eap/

  • All models are supported EAP EXCEPT GL-MT300N-V2, microuter-N300, GL-MT1300
1 Like

I have the exact same problem. I bought the SF1200 thinking it supported EAP networks (as not in the list), but it turns out with the gl inet interface it does not. However after installing the luci interface and connecting there to the EAP network (Network>wireless>scan), I succefully connected to the EAP network.

However, speed are limited to 20Mbps even though my network can do much more and I don’t know what is the limiting factor here.

This is a surprise though

Are these other models that don’t support EAP?

I think only MT300N-V2 and MT1300.

Ok thanks. I will check others that fit my needs.

can you explain better how you did it? maybe adding some images? I tried from the lights interface, but I couldn’t … I’m doing something wrong with the parameters, I’m not very experienced

Sorry but I returned the router as the speeds were not enough for my use case. As noted, from what I can remember I went to Network>wireless>scan, scanned on the 5G radio, filled in the right security info (protocol on auto, peap mschapv2 I think, id, password, TLS encryption), then connected. I had disconnection issues, but pinned that down on disconnection packed sent on the network and turn on the setting ignoring them.

If I remember well, the first time it didn’t work for unknown reasons. I had to reset the router and redo everything. However, on the second try everything went well. Except for the speed everything was stable and worked like a charm.

I have set all the parameters correctly and in the end it is committed, it does not appear in the gl ui screen but it works. the only flaw is that there are disconnections every so often that I don’t know s if they depend on the sf1200 or on the connection to be repeated … I don’t know how to correctly interpret the logs to be able to understand, if there was someone able to understand them, I will gladly share them