GL-X3000 Samba

I just tried to start Samba on a GL-X3000 running 4.0 firmware. Did not start.

Manually running “/etc/init.d/samba4 start” gave the error message “=== samba not enable”

The init script uses the command “uci -q get nas.conf.samba_enable” to test if samba is enabled.

However, “uci show nas.conf” shows a value for “nas.conf.samba_is_init” but nothing for “nas.conf.samba_enable”

Changing the test to “nas.conf.samba_is_init” instead of “nas.conf.samba_enable” seems to work for me. I don’t know if that is a legitimate fix or just a lucky hack. But I thought it would be good to report it.


Log into SSH and look in the /etc/config/nas file.

There should be the following line and you can add if it is missing (can use uci add/commit), so do not change the init script:

option samba_enable ‘1’

There should be the following line also, which it is not the same thing:

option samba_is_init ‘1’

I do not work for and I do not have formal association with GL.iNet