GL-X3000 Spitz AX - help with 5G modem (a long shot!)

Hi, I’ve recently received my new Spitz AX 4G router and am pleased with it.
I ordered a 4G version with the EM160 because the early bird 5G version was sold out.

I have several RM520N-GL modems and use them in Chinese (ali-express) routers successfully. I wanted to replace the 4G/EM160 with one of my 5G/RM502N-GL modems (which has always worked successfully in the Chinese routers) - like this model -

HUASIFEI WS7915AX WIFI6 dual band router wifi 5g HUASIFEI WS7915AX WIFI6 dual band router wifi 5g dual-core n_Shenzhen Huasifei Technology Co.,Ltd

To access the 4G/5G modem it’s necessary to take the SPITZ AX to pieces, and remove a heatsink and fan assembly, which I did successfully. However, when I insert my RM502 5G modem, the unit boots but then repeatedly power cycles about every 30 seconds. The power light comes on, the WiFi comes on for a few seconds and then goes off. This is a clear symptom of power issues - 5G modems in general are known for using more power than 4G modems. So I tried powering the unit with a PSU capable of supplying 5 amps - but still no difference.

I notice from the PCB that there are some unfilled spaces so I think more components may be installed when a 5G modem is used? I wonder if a CIRCUIT DIAGRAM is available, as I could easily add these extra components!

Any advice is appreciated!

Hi,Most of the RM520N-GL modules in circulation are working in USB mode. The Spitz AX router works in Pcie mode. It is possible that this difference is causing your 5G module to not work on the Spitz AX 4G router.please check your model,As picture below.
AA: Supports Pcie and USB
AP: Support Pcie Only
If you are AA. Can try to change to Pcie.

Thanks. This is useful information! I have bought another RM520 and checked that is in PCI-e mode, and I am glad to say this is working well!

I do have another issue - the EM160 (4G) that I removed from the X3000 was (obviously) in PCI-e mode, so I issued the AT command to make it operate in USB mode. I lost PCI-e connection in the X3000 - BUT - I have not got a USB connection.

EDIT - damm it. I have just checked the EM160 and it is marked AP as above - so it only works in PIC-e mode. But - I issued the command - AT+QCFG=“data_interface”,0,0 which changes data from PCI-e to USB, but the module obviously can’t do USB - so have I broken it?